Bug 821181 - yum update fails with many missing dependencies
yum update fails with many missing dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
: 821131 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-12 16:58 EDT by Herbert
Modified: 2014-01-21 18:21 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 13:02:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The second yum update log file is from a different host (mustard) and shows similar errors. (8.33 KB, text/plain)
2012-05-12 17:06 EDT, Herbert
no flags Details
FC16 yum update log (first attachment) (11.69 KB, text/plain)
2012-05-12 17:17 EDT, Herbert
no flags Details

  None (edit)
Description Herbert 2012-05-12 16:58:40 EDT
Description of problem:
yum update fails with many missing dependencies

Version-Release number of selected component (if applicable):
Fedora 16

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
See attachment file 

Expected results:


Additional info:
Comment 1 Herbert 2012-05-12 17:06:20 EDT
Created attachment 584068 [details]
The second yum update log file is from a different host (mustard) and shows similar errors.

My second attachment is the log file from a different host also running FC 16.
Comment 2 Herbert 2012-05-12 17:11:20 EDT
Comment on attachment 584068 [details]
The second yum update log file is from a different host (mustard) and shows similar errors.

This second yum update log file is from a different host (mustard) and shows similar errors.
Comment 3 Herbert 2012-05-12 17:17:56 EDT
Created attachment 584069 [details]
FC16 yum update log (first attachment)

This is the first attachment form a host (paprika) running Fedora 16 and shows the update log from the command ^yum update'.
Comment 4 Zdeněk Pavlas 2012-05-14 03:53:35 EDT
*** Bug 821131 has been marked as a duplicate of this bug. ***
Comment 5 James Antill 2012-05-14 13:02:18 EDT
 IN both cases you have pre-existing rpmdb problems. You can use install/reinstall/remove to fix these (and yum check to make sure they are gone).
 After fixing the pre-existing problems, yum will work again.
Comment 6 Herbert 2012-05-15 18:21:11 EDT
Thank you!
Following your advices I was able to fix the reported issues.

Note You need to log in before you can comment on or make changes to this bug.