Bug 821297 - PIDFile of clamsmtpd requires a non-existent /run/clamsmtp directory
PIDFile of clamsmtpd requires a non-existent /run/clamsmtp directory
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: clamsmtp (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Nathanael Noblet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-13 21:39 EDT by Bojan Smojver
Modified: 2012-05-26 03:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-24 19:58:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2012-05-13 21:39:35 EDT
Description of problem:
Daemon won't start, because this directory does not exist, so PID file cannot go into it.

Version-Release number of selected component (if applicable):
clamsmtp-1.10-6.fc17.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Attempt to start clamsmtpd.service.
2. Watch it fail because PID file cannot be created.
  
Actual results:
Fails to start.

Expected results:
This worked in F-16.

Additional info:
Maybe the PID can go into /run/clamd.clamsmtp or /etc/tmpfile.d/clamsmtp.conf has to gain one more line specifying the other directory.
Comment 1 Fedora Update System 2012-05-14 13:58:02 EDT
clamsmtp-1.10-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/clamsmtp-1.10-7.fc17
Comment 2 Fedora Update System 2012-05-14 13:58:11 EDT
clamsmtp-1.10-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/clamsmtp-1.10-7.fc16
Comment 3 Fedora Update System 2012-05-14 22:31:26 EDT
Package clamsmtp-1.10-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing clamsmtp-1.10-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7839/clamsmtp-1.10-7.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-05-15 12:13:16 EDT
clamsmtp-1.10-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/clamsmtp-1.10-8.fc17
Comment 5 Fedora Update System 2012-05-15 12:13:46 EDT
clamsmtp-1.10-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/clamsmtp-1.10-8.fc16
Comment 6 Fedora Update System 2012-05-24 19:58:05 EDT
clamsmtp-1.10-8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-05-26 03:24:19 EDT
clamsmtp-1.10-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.