Bug 821341 - Error messages needs to be in synced in UI and CLI
Error messages needs to be in synced in UI and CLI
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: rubygem-aeolus-cli (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: beta3
: ---
Assigned To: Mike Orazi
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 03:48 EDT by Aziza Karol
Modified: 2012-12-04 10:07 EST (History)
10 users (show)

See Also:
Fixed In Version: rubygem-aeolus-cli-0.7.3-1.el6cf
Doc Type: Bug Fix
Doc Text:
Web user interface and command line interface messages were not synchronized for image building. This bug fix synchronizes web user interface and command line interface error messages. Error messages display the same content for both web user interface and command line interface.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:07:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xml_err_1 (96.97 KB, image/png)
2012-10-10 03:28 EDT, pushpesh sharma
no flags Details
xml_err_2 (94.51 KB, image/png)
2012-10-10 03:28 EDT, pushpesh sharma
no flags Details

  None (edit)
Description Aziza Karol 2012-05-14 03:48:56 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
I removed "?" from the template <?xml version="1.0"  and tried building and image from CLI.

#aeolus-image build --target mock --template  rhel-x86_64-5.7-cf-tools.xml  --environment default
ERROR: The given Template does not conform to the TDL Schema, see below for specific details:
- Line: 1 => Expecting element template, got xml


then with the same template i tried building the image from UI.
I  got this message in UI "Failed to parse XML"

  
Actual results:
Error message in UI and CLI not in synced

Expected results:
Error messages in UI and CLI needs to be in synced.

Additional info:
rpm -qa | grep aeolus
aeolus-configure-2.5.3-1.el6.noarch
aeolus-conductor-0.8.13-1.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-all-0.8.13-1.el6_2.noarch
aeolus-conductor-doc-0.8.13-1.el6_2.noarch
aeolus-conductor-daemons-0.8.13-1.el6_2.noarch
Comment 1 Mike Orazi 2012-07-26 12:46:56 EDT
Ideally the map that makes the responses more readable can be in the shared code used between both the cli and conductor.
Comment 2 Mike Orazi 2012-08-16 10:33:37 EDT
Is there a commit/pull request for this?
Comment 3 Steve Linabery 2012-08-17 16:01:58 EDT
master has commits 3c21646  e882607
Comment 4 Steve Linabery 2012-08-17 16:02:32 EDT
(In reply to comment #3)
> master has commits 3c21646  e882607

Actually those commits are from 1.1 branch.
Comment 6 Rehana 2012-09-25 09:08:44 EDT
Retested, Observed that still it is displaying different errors on  CLI and GUI

On cli

aeolus-image build --target mock --template image.xml -E default
ERROR: The given Template does not conform to the TDL Schema, see below for specific details:
- Line: 1 => Expecting element template, got xml

ON conductor

Premature end of data in tag xml line 1

on 

rpm -qa |grep aeolus
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch


--XML file used --------

    <xml version="1.0"?>
    <template>
      <name>Fedora 15</name>
      <description>desc</description>
      <os>
        <rootpw>password</rootpw>
        <name>Fedora</name>
        <arch>x86_64</arch>
        <version>15</version>
        <install type="url">
          <url>http://download.fedoraproject.org/pub/fedora/linux/releases/15/Fedora/x86_64/os/</url>
        </install>
      </os>
      <repositories>
        <repository name="custom">
          <url>http://repos.fedorapeople.org/repos/aeolus/demo/webapp/</url>
          <signed>false</signed>
        </repository>
      </repositories>
    </template>
Comment 7 Martyn Taylor 2012-09-26 12:01:33 EDT
commit 8d134d24fa1e9bf45339323c088ef94239e9ef27
Author: Jason Guiditta <jguiditt@redhat.com>
Date:   Wed Sep 26 09:24:12 2012 -0400

    BZ821341: Error messages needs to be in synced in UI and CLI
    
    https://bugzilla.redhat.com/show_bug.cgi?id=821341
    
    Nokogiri behave differently if it is initialized with strict parsing
    config, as we were already doing in the TemplateXML object
    initializer.
Comment 10 Steve Linabery 2012-10-03 12:32:04 EDT
ET is not flipping this to ON_QA, so I am doing it manually.
Comment 11 pushpesh sharma 2012-10-10 03:27:04 EDT
[root@dhcp201-113 ~]# aeolus-image build --target mock --template  image_bad_xml.xml  --environment default- Line: 1 => Extra content at the end of the document
[root@dhcp201-113 ~]# vim image_bad_xml.xml 
[root@dhcp201-113 ~]# aeolus-image build --target mock --template  image_bad_xml.xml  --environment default
- Line: 22 => Premature end of data in tag xml line 1
[root@dhcp201-113 ~]# 


Web-UI and CLI messages seems to be insync for image building.

Verified on :

[root@dhcp201-113 ~]# rpm -qa|grep aeolus
aeolus-all-0.13.18-1.el6cf.noarch
aeolus-conductor-0.13.18-1.el6cf.noarch
rubygem-aeolus-cli-0.7.4-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-doc-0.13.18-1.el6cf.noarch
aeolus-conductor-daemons-0.13.18-1.el6cf.noarch
Comment 12 pushpesh sharma 2012-10-10 03:28:28 EDT
Created attachment 624639 [details]
xml_err_1
Comment 13 pushpesh sharma 2012-10-10 03:28:50 EDT
Created attachment 624640 [details]
xml_err_2
Comment 15 errata-xmlrpc 2012-12-04 10:07:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.