This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 821388 - Booting 17 TC5 liveusb fails on a MacBook7,1
Booting 17 TC5 liveusb fails on a MacBook7,1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 06:15 EDT by Mr.doob
Modified: 2012-05-29 08:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 08:29:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dracut warning (611.09 KB, image/jpeg)
2012-05-14 06:15 EDT, Mr.doob
no flags Details
ls -l /dev/disk/* (567.13 KB, image/jpeg)
2012-05-15 10:59 EDT, Mr.doob
no flags Details
/lib/udev/cdrom_id --debug /dev/sr0 (807.67 KB, image/jpeg)
2012-05-15 10:59 EDT, Mr.doob
no flags Details

  None (edit)
Description Mr.doob 2012-05-14 06:15:56 EDT
Created attachment 584313 [details]
dracut warning

Description of problem:
Boot fails (see attachment).

How reproducible:
Created a Fedora-17.TC5-x86_64-Live-Desktop liveusb using the Windows liveusb-creator and booted the system with it.
Comment 1 Mr.doob 2012-05-14 06:42:29 EDT
Just tried with a Macmini3,1 and I'm having the same problem, so I guess is not machine specific.
Comment 2 Harald Hoyer 2012-05-15 06:02:52 EDT
Boot from the CD, then run these commands in the shell

# ls -l /dev/disk/*
# /lib/udev/cdrom_id --debug /dev/sr0

and post a photo, please.
Comment 3 Mr.doob 2012-05-15 10:59:07 EDT
Created attachment 584683 [details]
ls -l /dev/disk/*
Comment 4 Mr.doob 2012-05-15 10:59:40 EDT
Created attachment 584684 [details]
/lib/udev/cdrom_id --debug /dev/sr0
Comment 5 Harald Hoyer 2012-05-29 08:03:18 EDT
Seems like a kernel module is missing for the CDROM in the initramfs.

Do you happen to know the cdrom kernel module name?
Comment 6 Mr.doob 2012-05-29 08:29:25 EDT
Turns out it was an issue of liveusb-creator. If I use `dd` for creating the live usb it boots fine.

Note You need to log in before you can comment on or make changes to this bug.