Bug 821394 - Running jbpm "evaluation" sample process error--javax.jcr.PathNotFoundException: com.sample.evaluation-image
Running jbpm "evaluation" sample process error--javax.jcr.PathNotFoundExcepti...
Status: CLOSED NOTABUG
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM Console (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kris Verlaenen
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 07:10 EDT by Ryan Zhang
Modified: 2014-06-09 07:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-09 07:07:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (161.32 KB, text/x-log)
2012-05-14 07:10 EDT, Ryan Zhang
no flags Details

  None (edit)
Description Ryan Zhang 2012-05-14 07:10:12 EDT
Description of problem:
Error is found when click process-overview in jbpm console.

2012-05-14 15:27:39,254 ERROR [org.drools.guvnor.server.files.RepositoryServlet] (http-127.0.0.1-8080-10) javax.jcr.PathNotFoundException: com.sample.evaluation-image
org.drools.repository.RulesRepositoryException: javax.jcr.PathNotFoundException: com.sample.evaluation-image
	at org.drools.repository.PackageItem.loadAsset(PackageItem.java:755)
	at org.drools.guvnor.server.files.PackageDeploymentServlet$1.execute(PackageDeploymentServlet.java:173)
	at org.drools.guvnor.server.files.RepositoryServlet.doAuthorizedAction(RepositoryServlet.java:75)
	at org.drools.guvnor.server.files.PackageDeploymentServlet.doGet(PackageDeploymentServlet.java:130)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:625)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.jboss.seam.web.ContextFilter$1.process(ContextFilter.java:42)
	at org.jboss.seam.servlet.ContextualHttpServletRequest.run(ContextualHttpServletRequest.java:65)
	at org.jboss.seam.web.ContextFilter.doFilter(ContextFilter.java:37)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:183)
	at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:95)
	at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
	at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.jboss.web.tomcat.service.request.ActiveRequestResponseCacheValve.internalProcess(ActiveRequestResponseCacheValve.java:74)
	at org.jboss.web.tomcat.service.request.ActiveRequestResponseCacheValve.invoke(ActiveRequestResponseCacheValve.java:47)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:599)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:451)
	at java.lang.Thread.run(Thread.java:662)
Caused by: javax.jcr.PathNotFoundException: com.sample.evaluation-image
	at org.apache.jackrabbit.core.NodeImpl$8.perform(NodeImpl.java:2135)
	at org.apache.jackrabbit.core.NodeImpl$8.perform(NodeImpl.java:2129)
	at org.apache.jackrabbit.core.session.SessionState.perform(SessionState.java:200)
	at org.apache.jackrabbit.core.ItemImpl.perform(ItemImpl.java:91)
	at org.apache.jackrabbit.core.NodeImpl.getNode(NodeImpl.java:2129)
	at org.drools.repository.PackageItem.loadAsset(PackageItem.java:751)
	... 32 more

The full server.log also attached.

Version-Release number of selected component (if applicable):

It happens to BRMS 5.3 ER7
How reproducible:


Steps to Reproduce:
1. import jbpm_examples_repository.xml in jboss-brms console
2. click the process-overview in business-central consol
3.The error occures in server.log. The function seems fine.
  
Actual results:
Error found in the server.log

Expected results:


Additional info:
Comment 1 Ryan Zhang 2012-05-14 07:10:53 EDT
Created attachment 584333 [details]
server.log
Comment 2 Kris Verlaenen 2012-05-14 21:01:31 EDT
The error is indeed one that can be ignored because in the case of the evaluation example, the process diagram is provided as part of the classpath.  For other cases (created by the end user), this however would probably not be the case, in which the exception would be meaningful.

In the case of the evaluation example, the exception can safely be ignored.  For user created cases, the exception would mean that the process instance diagram view would not be able to show the diagram (and the user would get an appropriate warning when doing so).
Comment 3 Lukáš Petrovický 2012-10-17 04:00:26 EDT
Given comment 2, can this be closed, Ryan?

Note You need to log in before you can comment on or make changes to this bug.