Bug 821411 - Improve client window-manager integration
Improve client window-manager integration
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 08:18 EDT by Marc-Andre Lureau
Modified: 2014-02-18 16:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-18 16:00:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc-Andre Lureau 2012-05-14 08:18:05 EDT
Description of problem:

Some key/mouse combinations are catched by the client-side window manager, preventing the guest-side window manager from using those combinations.

In window mode, it makes sense to leave the client window manager handling those combinations, but in full-screen we may want to leave all this handling to the guest window manager.
Comment 2 RHEL Product and Program Management 2012-07-10 04:44:50 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 22:00:16 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 David Blechter 2012-10-05 08:28:27 EDT
out of time for 6.4 -> moving to 6.5
Comment 7 Jonathon Jongsma 2013-09-05 10:55:13 EDT
Marc-andre, what specific key combinations are you referring to?
Comment 8 Marc-Andre Lureau 2013-09-05 11:27:50 EDT
(In reply to Jonathon Jongsma from comment #7)
> Marc-andre, what specific key combinations are you referring to?

I was thinking in particular about the Win+LeftButton. There might be other window manager bindings & actions that you can trigger. I haven't looked at it recently.
Comment 9 RHEL Product and Program Management 2013-10-14 01:00:11 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 10 Marc-Andre Lureau 2014-02-18 16:00:52 EST
tbh, this is mainly a metacity/gnome-shell issue which will be difficult to solve since it's done like this by design.

As reporter of the bug, I take decision to close it, and it should be taken upstream first.
Comment 11 Marc-Andre Lureau 2014-02-18 16:01:16 EST
tbh, this is mainly a metacity/gnome-shell issue which will be difficult to solve since it's done like this by design.

As reporter of the bug, I take decision to close it, and it should be taken upstream first.

Note You need to log in before you can comment on or make changes to this bug.