Bug 821430 - RichFaces Showcase not deployable because of non-existing EAP dependencies
RichFaces Showcase not deployable because of non-existing EAP dependencies
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: RichFaces, Maven (Show other bugs)
2.0.0.ER5
Unspecified Unspecified
high Severity high
: ---
: 2.0.0.ER6
Assigned To: Marek Novotny
Pavol Pitonak
showcase
:
Depends On: 821442
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 09:08 EDT by Pavol Pitonak
Modified: 2012-06-22 03:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 03:32:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPAPP-9016 None Closed Obsolete cssparser sac versions in jboss-component-version-master 2012-06-04 11:06:18 EDT

  None (edit)
Description Pavol Pitonak 2012-05-14 09:08:20 EDT
Description of problem:
Showcase declares net.sourceforge.cssparser and org.w3c.css.sac modules which are no longer in EAP 6.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. deploy RichFaces Showcase
2. see server log
  
Actual results:
Caused by: org.jboss.modules.ModuleNotFoundException: Module net.sourceforge.cssparser:main is not found in local module loader @c75e4fc (roots: /data/soft/jboss-eap-6.0.0.ER6/modules)
        at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:126)
        at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275)
        at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222)
        at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:94)
        at org.jboss.modules.Module.addPaths(Module.java:841)
        at org.jboss.modules.Module.link(Module.java:1181)
        at org.jboss.modules.Module.relinkIfNecessary(Module.java:1207)
        at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208)
        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:71) [jboss-as-server-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
        ... 5 more

Expected results:
application deploys to EAP 6.0.0.ER6 without exceptions

Additional info:
Comment 1 JBoss JIRA Server 2012-05-15 20:42:09 EDT
Paul Gier <pgier@redhat.com> made a comment on jira JBPAPP-9016

Verified that cssparser and sac are not referenced by any eap 6 components, and these have been removed from the BOMs.
http://git.app.eng.bos.redhat.com/?p=jboss/jboss-component-management.git;a=commit;h=7ac896a284baf7b28ba9a06c6930a4457116f9e0

Also note that even if a dependency is listed in the BOMs, this does not require layered products to use these versions in all cases.  The version master BOM just specifies properties, but these can be overridden where appropriate.
Comment 2 JBoss JIRA Server 2012-05-15 20:44:54 EDT
Paul Gier <pgier@redhat.com> made a comment on jira JBPAPP-9016

Fernando, it looks like sac is no longer in the EAP6 tag.  Should the cssparser build also be untagged?
https://brewweb.devel.redhat.com/buildinfo?buildID=204412
Comment 3 JBoss JIRA Server 2012-05-16 18:01:42 EDT
Fernando Nasser <fnasser@redhat.com> updated the status of jira JBPAPP-9016 to Resolved
Comment 4 JBoss JIRA Server 2012-05-16 19:31:33 EDT
Paul Gier <pgier@redhat.com> updated the status of jira JBPAPP-9016 to Reopened
Comment 5 JBoss JIRA Server 2012-05-16 19:33:56 EDT
Paul Gier <pgier@redhat.com> made a comment on jira JBPAPP-9016

Fernando, can cssparser be untagged from eap6?
Comment 6 JBoss JIRA Server 2012-05-17 18:15:12 EDT
Fernando Nasser <fnasser@redhat.com> updated the status of jira JBPAPP-9016 to Resolved
Comment 7 JBoss JIRA Server 2012-05-17 18:15:12 EDT
Fernando Nasser <fnasser@redhat.com> made a comment on jira JBPAPP-9016

Untagged cssparser-0.9.5-4_redhat_1.ep6.el6.1

We can tag it back if needed.  -build regening, please
regen -latest to see this change there.
Comment 8 Marek Novotny 2012-05-20 04:18:11 EDT
I will roll back to community versions for both cssparser 0.9.5 and sac dependencies.
Comment 9 JBoss JIRA Server 2012-06-04 03:10:04 EDT
Karel Piwko <kpiwko@redhat.com> updated the status of jira JBPAPP-9016 to Closed
Comment 10 JBoss JIRA Server 2012-06-04 03:10:04 EDT
Karel Piwko <kpiwko@redhat.com> made a comment on jira JBPAPP-9016

Verified in ER8.

Note You need to log in before you can comment on or make changes to this bug.