Bug 821442 - RichFaces: Missing dependency on net.sourceforge.cssparser:cssparser
RichFaces: Missing dependency on net.sourceforge.cssparser:cssparser
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Maven, RichFaces (Show other bugs)
2.0.0.ER5
Unspecified Unspecified
unspecified Severity high
: ---
: 2.0.0.ER6
Assigned To: Marek Novotny
Pavol Pitonak
:
Depends On:
Blocks: 821430
  Show dependency treegraph
 
Reported: 2012-05-14 09:47 EDT by Karel Piwko
Modified: 2012-06-22 03:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 03:32:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Piwko 2012-05-14 09:47:57 EDT
Description of problem:

RichFaces depends on 

<dependency>
    <groupId>net.sourceforge.cssparser</groupId>
    <artifactId>cssparser</artifactId>
</dependency>

This dependency was originally a part of module in AS7.

Since EAP ER5, this file is no longer distributed in EAP6 repository and version range [0.9.5,0.9.5-redhat-1] fails to retrieve community version.

Workaround:

Force community version to be used in <dependencyManagement>

<dependency>
    <groupId>net.sourceforge.cssparser</groupId>
    <artifactId>cssparser</artifactId>
    <version>0.9.5</version>
</dependency>

This workaround must be used while building RichFaces or using RichFaces BOM.
Comment 1 Marek Novotny 2012-05-22 07:54:02 EDT
removed productized version and back to pure community 0.9.5

Note You need to log in before you can comment on or make changes to this bug.