Bug 821460 - Mistake in documentation of Modify Command in Drools Integration User Guide
Mistake in documentation of Modify Command in Drools Integration User Guide
Status: CLOSED NOTABUG
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: Documentation (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: lcarlon
Andrew Ross
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 10:54 EDT by Radovan Synek
Modified: 2013-10-20 18:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 19:22:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radovan Synek 2012-05-14 10:54:45 EDT
http://docs.jboss.org/drools/release/5.3.0.Final/droolsjbpm-integration-docs/html_single/#d0e1177

JAXB:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<batch-execution lookup="ksession1">
    <modify fact-handle="0:234:345:456:567">
        <set value="30" accessor="age"/>
    </modify>
</batch-execution>

This command format gives me NPE in org.drools.command.runtime.rule.ModifyCommand.getMvelExpr() because setters are null. Instead, using Command API and marshalling works fine, but the marshalled command is different:

<batch-execution>
  <modify fact-handle="...">
    <setters>
      <item accessor="name" value="..."/>
      <item accessor="age" value="..."/>
    </setters>
  </modify>
</batch-execution>
Comment 1 lcarlon 2012-05-16 19:22:41 EDT
Hi Ryan, 

This issue needs to be raised against the community docs. The integration docs are not (yet) part of the BRMS docs.

Thanks
Lee

Note You need to log in before you can comment on or make changes to this bug.