Bug 821471 - TorqueBox Sometimes Fails to Boot When Multiple Clustered Applications are Deployed
TorqueBox Sometimes Fails to Boot When Multiple Clustered Applications are De...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: TorqueBox (Show other bugs)
2.0.0.ER5
Unspecified Unspecified
high Severity high
: ---
: 2.0.0.CR1
Assigned To: Bob McWhirter
Oliver Kišš
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 11:26 EDT by Bob McWhirter
Modified: 2015-08-02 19:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 06:47:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TORQUE-808 None Closed TorqueBox Sometimes Fails to Boot When Multiple Clustered Applications are Deployed 2012-07-26 17:58:04 EDT

  None (edit)
Description Bob McWhirter 2012-05-14 11:26:40 EDT
When at least two applications are deployed to a clustered TorqueBox, TorqueBox will frequently fail to boot with the error "Caused by: org.jboss.msc.service.DuplicateServiceException: Service jboss.cluster.web is already registered".

Stack trace of this happening:
https://gist.github.com/ccb7d233795218372158
Comment 1 Bob McWhirter 2012-05-14 11:27:30 EDT
Supposedly fixed in EAP (?) via

https://issues.jboss.org/browse/AS7-4346
Comment 2 Karel Piwko 2012-05-15 04:00:58 EDT
Rescheduled to 2.0.0.ER6, since this is likely an EAP issue which was already fixed in https://issues.jboss.org/browse/JBPAPP-8595.
Comment 3 mark yarborough 2012-06-18 11:44:16 EDT
Karel to double check if already verified.
Comment 5 Karel Piwko 2012-06-22 06:47:12 EDT
Closing as CURRENTRELEASE.
Comment 6 JBoss JIRA Server 2012-06-25 09:42:41 EDT
Benjamin Browning <bbrowning@redhat.com> updated the status of jira TORQUE-808 to Resolved
Comment 7 JBoss JIRA Server 2012-06-25 09:42:41 EDT
Benjamin Browning <bbrowning@redhat.com> made a comment on jira TORQUE-808

Fixed by upgrading to an AS7 incremental
Comment 8 JBoss JIRA Server 2012-07-26 17:58:05 EDT
Benjamin Browning <bbrowning@redhat.com> updated the status of jira TORQUE-808 to Closed

Note You need to log in before you can comment on or make changes to this bug.