Bug 821491 - User on IRC reported that he was getting an error when adding a key to the Web Console: "Raw content can't be blank"
User on IRC reported that he was getting an error when adding a key to the We...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 12:35 EDT by Nam Duong
Modified: 2015-05-14 21:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:30:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss (91.17 KB, image/png)
2012-05-14 13:12 EDT, Nam Duong
no flags Details

  None (edit)
Description Nam Duong 2012-05-14 12:35:05 EDT
Description of problem:
When the user tried to post his public key on the Web Console with the following:
Name: PBJ
PubKey: AAAAB3NzaC1yc2EAAAADAQABAAABAQCYF+UEbl2WwngESRbDVundAyKsC7OQgkYNZ2nxP1w2gW2WuxliQ6iWALlpfWShviSLo8JGVJOrGEMHGCYaQUcOw5p9WxDvALIWmoBUaMu1OopPBShBO4ffeWzNDr/HKt3dGyQoPyb89DLOO+k/E1e+Ppk5ASAycD/GKSpT8yf1UZNnTwH8oATwuEg85QLTbvIlrvoOYdibcP7FtuvefUKtePm0xWHD0z9sy8lui+GENdZsiMoVjMnI1EpzPiq6oBQrfNq42VaTowU6CNAhtS+7zJXHSf+G1CGPxPHP/JW6ODNOrZKvuf/uob8q09sOOO2VsIHqMkO78T7zy1h9LzIz mac book

He got an error on the web console:
"Raw content can't be blank"

Workaround:
Remove the text " book" and it worked.  I went further and removed " mac book" and it also worked for me.

NOTE: The user's public key is different, and contained " pebble ubuntu" (the extra space is not a typo).  I used my own key to reproduce.

Also note that when I use the rhc client tools "rhc sshkey add ...", I don't get an error and the key is posted as:
AAAAB3NzaC1yc2EAAAADAQABAAABAQCYF+UEbl2WwngESRbDVundAyKsC7OQgkYNZ2nxP1w2gW2WuxliQ6iWALlpfWShviSLo8JGVJOrGEMHGCYaQUcOw5p9WxDvALIWmoBUaMu1OopPBShBO4ffeWzNDr/HKt3dGyQoPyb89DLOO+k/E1e+Ppk5ASAycD/GKSpT8yf1UZNnTwH8oATwuEg85QLTbvIlrvoOYdibcP7FtuvefUKtePm0xWHD0z9sy8lui+GENdZsiMoVjMnI1EpzPiq6oBQrfNq42VaTowU6CNAhtS+7zJXHSf+G1CGPxPHP/JW6ODNOrZKvuf/uob8q09sOOO2VsIHqMkO78T7zy1h9LzIz
Comment 1 Clayton Coleman 2012-05-14 13:02:51 EDT
The key type must be pasted - generally that's the first part of the public key.  Did the user exclude "ssh-rsa " from the beginning of his key paste?
Comment 2 Nam Duong 2012-05-14 13:11:17 EDT
The key contents did include ssh-rsa:
ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQCYF+UEbl2WwngESRbDVundAyKsC7OQgkYNZ2nxP1w2gW2WuxliQ6iWALlpfWShviSLo8JGVJOrGEMHGCYaQUcOw5p9WxDvALIWmoBUaMu1OopPBShBO4ffeWzNDr/HKt3dGyQoPyb89DLOO+k/E1e+Ppk5ASAycD/GKSpT8yf1UZNnTwH8oATwuEg85QLTbvIlrvoOYdibcP7FtuvefUKtePm0xWHD0z9sy8lui+GENdZsiMoVjMnI1EpzPiq6oBQrfNq42VaTowU6CNAhtS+7zJXHSf+G1CGPxPHP/JW6ODNOrZKvuf/uob8q09sOOO2VsIHqMkO78T7zy1h9LzIz mac book

That was a copy/paste error on my part.
Comment 3 Nam Duong 2012-05-14 13:12:41 EDT
Created attachment 584412 [details]
ss
Comment 4 Clayton Coleman 2012-08-29 18:23:03 EDT
Try this again, it should be fixed now.
Comment 5 Yujie Zhang 2012-08-30 03:10:37 EDT
(In reply to comment #4)
Tested this issue on PROD, it has been fixed now, thanks.

Note You need to log in before you can comment on or make changes to this bug.