Bug 821535 - There isn't any "Capture" device in alsamixer on SPICE VM.
There isn't any "Capture" device in alsamixer on SPICE VM.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: alsa-utils (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jaroslav Kysela
Desktop QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 16:16 EDT by Bill Sanford
Modified: 2012-05-29 14:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 14:29:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from 'alsa-info.sh --no-upload' (7.33 KB, text/plain)
2012-05-16 10:31 EDT, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2012-05-14 16:16:09 EDT
Description of problem:
The alsamixer on the SPICE VM sees the playback device and does not see the capture device.

Version-Release number of selected component (if applicable):
RHEL 6.3

How reproducible:
100%

Steps to Reproduce:
1. Create a RHEL 6.3 VM in a RHEV-M ic155.2 environment.
2. From the SPICE client, run alsamixer to select sound card and set volume.
3. Launch SPICE VM and run alsamixer and see there is no "Capture" device.
  
Actual results:
The SPICE VM has no "Capture" device to set volume.

Expected results:
The SPICE VM has a "Capture" device to set volume.

Additional info:

Client - RHEL 6.3 32 bit 
spice-usb-share-4.9-9.el6.i686 
spice-vdagent-0.8.1-3.el6.i686 
spice-glib-0.11-9.el6.i686 
spice-client-0.8.2-15.el6.i686 
spice-xpi-2.7-19.el6.i686 
spice-gtk-0.11-9.el6.i686 
kmod-kspiceusb-rhel60-4.9-14.el6.i686 
usbredir-0.4.3-1.el6.i686 
xorg-x11-drv-qxl-0.0.14-13.el6_2.i686 
virt-viewer-0.5.2-8.el6.i686 


Guest - RHEL 6.3 32 bit 
spice-vdagent-0.8.1-3.el6.i686 
xorg-x11-drv-qxl-0.0.14-13.el6_2.i686 
rhev-agent-2.3.16-3.el6.i386 


Host - RHEL 6.3 32 bit 
spice-server-0.10.1-7.el6.x86_64 
spice-vdagent-0.8.1-3.el6.x86_64 
usbredir-0.4.3-1.el6.x86_64 
qemu-kvm-0.12.1.2-2.292.el6.x86_64 
qemu-kvm-tools-0.12.1.2-2.292.el6.x86_64 
xorg-x11-drv-qxl-0.0.14-13.el6_2.x86_64 


RHEV-M ic155.2 
rhevm-spice-client-x64-cab-3.0-29.el6.noarch 
rhevm-spice-client-x86-cab-3.0-29.el6.noarch 
rhevm-spice-client-x64-msi-3.0-29.el6.noarch 
spice-vdagent-0.8.1-3.el6.x86_64 
rhevm-spice-client-x86-msi-3.0-29.el6.noarch 
xorg-x11-drv-qxl-0.0.14-13.el6_2.x86_64 
rhevm-3.0.3_0001-3.el6.x86_64 
rhev-guest-tools-iso-3.0-37.noarch 
rhevm-userportal-3.0.3_0001-3.el6.x86_64 
rhevm-admin-portal-wpf-3.0-50.el6_2.noarch
Comment 1 Bill Sanford 2012-05-14 16:18:29 EDT
I have tried a stand alone mic with one plug input and Clear Chat Pro - USB Headset/Mic.
Comment 2 Bill Sanford 2012-05-14 16:40:11 EDT
The reason I put this in alsamixer, is that the same configuration but with a Windows 7 Guest, works.
Comment 3 Jaroslav Kysela 2012-05-14 18:05:06 EDT
Please, attach output from 'alsa-info.sh --no-upload'.
Comment 4 Bill Sanford 2012-05-16 10:31:00 EDT
Created attachment 584989 [details]
Output from 'alsa-info.sh --no-upload'
Comment 5 Bill Sanford 2012-05-16 10:31:40 EDT
This is the output from the SPICE guest.
Comment 6 Jaroslav Kysela 2012-05-16 10:38:47 EDT
The ALSA PCM capture device is three, but the virtual HDA codec does not have any volume control for the capture path, so the mixer interface does not offer it.

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

ARECORD

**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
  Subdevices: 1/1
  Subdevice #0: subdevice #0



Just run 'arecord -f cd a.wav' or any other PCM capture session to test the sound input on guest.
Comment 7 Bill Sanford 2012-05-16 13:44:04 EDT
After about the third reboot of the VM, now it works.
Comment 8 Jaroslav Kysela 2012-05-16 13:53:48 EDT
It means that in some boot cases the capture volume control is not present?

It appears like a bug. It would be good to attach also 'alsa-info.sh --no-upload' for the working state.
Comment 9 Bill Sanford 2012-05-29 14:29:41 EDT
I just installed RHEL6.3-20120516.0 as a SPICE VM and I am not seeing this behavior. 

If this is an issue again, I will enter the bug with the files from 'alsa-info.sh --no-upload' in the working and non-working state.

Note You need to log in before you can comment on or make changes to this bug.