Bug 821538 - strip timestamps out of summaries.
strip timestamps out of summaries.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 16:31 EDT by Dave Jones
Modified: 2016-11-30 19:42 EST (History)
10 users (show)

See Also:
Fixed In Version: 2.0.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-10 05:49:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2012-05-14 16:31:34 EDT
abrt files bugs with summaries like..

[abrt] kernel: [139792.425953] WARNING: at drivers/mmc/host/sdhci.c:962 sdhci_send_command+0xc16/0xd00 [sdhci]()

The timestamp is rarely useful, so please strip it out of the summary.
This also makes the summaries easier to see duplicates abrt missed when looking at bug lists.

bonus points: remove 'kernel:' too. We know it's a kernel bug ;-)
Comment 1 Jiri Moskovcak 2012-08-09 17:34:49 EDT
Jakub, since you're looking into kerneloops report format, please take a look at this too.
Comment 2 Jakub Filak 2012-08-10 04:02:04 EDT
ad bonus points: 'kernel' string is already removed in libreport-2.0.10:

commit d89a239d66222d3b8e3d4b1b1af5dd64e5e3777f
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Mon Feb 20 09:57:17 2012 +0100

    bugzilla: exclude appending package name for kernel oops
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>


I'll take care about the rest
Comment 3 Jakub Filak 2012-08-10 05:06:00 EDT
Regarding to the following commit:

commit 30b97427e3028dddc32b69a23907ebdf9c63b26e
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Mon Feb 20 14:38:19 2012 +0100

    dump-oops: fix removing jiffies time stamp
    
    jiffies are unsigned long, so it can be 2^64 long, which is
    20 decimal digits
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>

striping the timestamp out of the summuary should be fixed in abrt-2.0.9

Note You need to log in before you can comment on or make changes to this bug.