Bug 821558 - fenced issues causing failures when stopping cman
fenced issues causing failures when stopping cman
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: David Teigland
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 18:45 EDT by Corey Marthaler
Modified: 2012-08-20 18:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 18:26:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2012-05-14 18:45:30 EDT
Description of problem:
I see 'cman stop' fail from time to time due to fenced issues.

[root@hayes-01 ~]# service clvmd stop
Signaling clvmd to exit                                    [  OK  ]
clvmd terminated                                           [  OK  ]
[root@hayes-01 ~]# service cmirrord stop
Stopping cmirrord:                                         [  OK  ]
[root@hayes-01 ~]# service cman stop
Stopping cluster: 
   Leaving fence domain... fence_tool: leave: can't communicate with fenced
                                                           [FAILED]
[root@hayes-01 ~]# service cman stop
Stopping cluster: 
   Leaving fence domain... fence_tool: leave: can't communicate with fenced
                                                           [FAILED]

[root@hayes-01 ~]# ps -ef | grep fence
root       442  1814  0 17:37 pts/0    00:00:00 grep fence
root     32372     1  0 17:16 ?        00:00:00 fenced

[root@hayes-01 ~]# killall fenced
[root@hayes-01 ~]#  service cman stop
Stopping cluster: 
   Leaving fence domain... fence_tool: leave: can't communicate with fenced
                                                           [FAILED]
[root@hayes-01 ~]# fence_tool leave
[root@hayes-01 ~]#  service cman stop
Stopping cluster: 
   Leaving fence domain... fence_tool: leave: can't communicate with fenced
                                                           [FAILED]


Version-Release number of selected component (if applicable):
[root@hayes-01 ~]# rpm -qa | grep cluster
cluster-glue-libs-1.0.5-6.el6.x86_64
lvm2-cluster-2.02.95-8.el6.x86_64
clusterlib-3.0.12.1-31.el6.x86_64
cluster-glue-1.0.5-6.el6.x86_64
pacemaker-cluster-libs-1.1.7-6.el6.x86_64
modcluster-0.16.2-18.el6.x86_64


How reproducible:
Often
Comment 1 Fabio Massimo Di Nitto 2012-05-14 23:26:51 EDT
Reassigning to fenced maintainer.
Comment 2 David Teigland 2012-05-15 11:06:39 EDT
I don't see any recent changes to fenced or fence_tool, which makes me think this could be an init script or selinux problem.  Corey, I'll take a look at the machine next time you see this.
Comment 3 David Teigland 2012-05-15 12:16:14 EDT
If fenced isn't running, cman init shouldn't attempt to run fence_tool leave.  But that's what it looks like it's doing above even after killall.
Comment 4 Corey Marthaler 2012-05-16 13:07:14 EDT
this appears related to bug 741434 and is probably some kind of selinux issue.
Comment 5 RHEL Product and Program Management 2012-07-10 01:48:43 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 19:09:29 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 David Teigland 2012-07-30 11:22:47 EDT
Corey, I think you could close this if you haven't seen it again.
Comment 8 Corey Marthaler 2012-08-20 18:26:56 EDT
I can't reproduce this issue. Closing...

Note You need to log in before you can comment on or make changes to this bug.