Bug 822024 - text install RHEL7 as a KVM guest with 512M ram failed
text install RHEL7 as a KVM guest with 512M ram failed
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 01:59 EDT by Xiaoqing Wei
Modified: 2012-12-06 15:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 15:58:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg in guest. (76.04 KB, text/plain)
2012-05-16 01:59 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2012-05-16 01:59:29 EDT
Created attachment 584860 [details]
dmesg in guest.

Description of problem:

text install RHEL7 as a KVM guest with 512M ram failed

Version-Release number of selected component (if applicable):
anaconda-17.25-1.el7 shipped with RHEL-7.0-20120510.n.0
kernel-3.3.0-0.12.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
install a RHEL-7.0-20120510.n.0 as a kvm guest on
 host_RHEL-7.0-20120510.n.0 in text mode :

qemu-kvm -monitor stdio -S -chardev socket,id=serial_id_20120515-100205-27N6,path=/tmp/serial-20120515-100205-27N6,server,nowait -device isa-serial,chardev=serial_id_20120515-100205-27N6 -device ich9-usb-uhci1,id=usb1,multifunction=off,bus=pci.0,addr=0x4 -drive file='/home/text_512.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,format=qcow2,aio=native -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,id=virtio-disk1 -device virtio-net-pci,netdev=idXkybk8,mac=9a:dc:7e:db:33:1f,id=ndev00idXkybk8,bus=pci.0,addr=0x3 -netdev tap,id=idXkybk8,vhost=on \
\
 -m 512 \
\
-smp 1,cores=1,threads=1,sockets=1 -cpu 'Nehalem' \
\
-drive file='/home/kvm_autotest_root/iso/linux/RHEL7.0-Server-x86_64.iso',index=1,if=none,id=drive-ide0-0-0,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -device usb-tablet,id=usb-tablet1,bus=usb1.0 -spice port=8010,disable-ticketing -vga qxl -rtc base=localtime,clock=host,driftfix=slew -M pc-1.0 -boot order=cdn,once=c,menu=off   -enable-kvm -nodefaults

2.
3.
  
Actual results:
guest will stuck at some point of installation,
dmesg will be attached.

Expected results:
rhel7 install successfully as rhel6

Additional info:

1) same cmd works fine for rhel6_as_a_kvm_guest on **rhel7_host**
2) tried rhel7_as_a_kvm_guest on **rhel6_host**, fail
3) increase the rhel7 guest RAM to "-m 768", guest install successfully.
Comment 1 Xiaoqing Wei 2012-05-16 02:04:08 EDT
Since there's still not a conclusion on what's the supportable minimal RAM for RHEL7_as_a_kvm_guest, if we dont expect to support such a mini guest, pls feel free to close this bug.


Regards,
Xiaoqing.
Comment 4 Chris Lumens 2012-05-23 10:33:27 EDT
At the moment you start getting weird behavior, can you grab the output of the top command, sorted by memory usage?  I'm wondering what's eating up all the memory.
Comment 5 Xiaoqing Wei 2012-05-27 02:26:20 EDT
(In reply to comment #4)
> At the moment you start getting weird behavior, can you grab the output of
> the top command, sorted by memory usage?  I'm wondering what's eating up all
> the memory.

Will test it over alpha2
Comment 6 Xiaoqing Wei 2012-07-15 22:33:36 EDT
Try to PXE install the RHEL.7.0-20120711.2 with 512MB RAM,
the squashfs.img cant be uncompress, guest complaining of 'no space left'.

with 768MB RAM, guest install works fine.
Comment 7 Jesse Keating 2012-07-18 12:27:38 EDT
With PXE the kernel, initrd, and squashfs will be stored in memory, which is quite a lot of memory pressure.  It may be unreasonable to expect that scenario to work in 512megs of ram.

Note You need to log in before you can comment on or make changes to this bug.