Bug 822097 - Remove invalid deps in 5.3.x/guvnor-distribution/pom.xml
Remove invalid deps in 5.3.x/guvnor-distribution/pom.xml
Status: VERIFIED
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRM (Guvnor) (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Geoffrey De Smet
Ryan Zhang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 06:33 EDT by Ryan Zhang
Modified: 2012-05-27 21:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Zhang 2012-05-16 06:33:20 EDT
Description of problem:
I believe this dependency in Guvnor 5.3.x is invalid.
https://github.com/droolsjbpm/guvnor/blob/5.3.x/guvnor-distribution/pom.xml

<dependency>
<rzhang>       <groupId>org.drools</groupId>
<rzhang>       <artifactId>guvnor-distribution-wars</artifactId>
<rzhang>       <type>war</type>
<rzhang>       <classifier>jboss-as-6.0</classifier>
<rzhang> </dependency>

Have comfirmed with Geoffrey, he can fix it easilly.but needs to grant the  block+ for this issue.

Please grant this issue, it's a simple  bug for product build. It needs to be fixed.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ryan Zhang 2012-05-16 06:34:41 EDT
This is only a build time issue, so no need to verify by QE.
Comment 2 Geoffrey De Smet 2012-05-16 06:36:51 EDT
This is an easy fix, I got it locally. Ping me when I can push the change.
Comment 3 Geoffrey De Smet 2012-05-16 07:44:53 EDT
Fixed on 5.3.x. Master and 5.4.x do not suffer from it.
https://github.com/droolsjbpm/guvnor/commit/68783361b1914efb9160d017d352bc08cf14fb46
Comment 4 Ryan Zhang 2012-05-21 05:27:15 EDT
This is a build issue. Verified and I would put it in VERIFIED directly.

Note You need to log in before you can comment on or make changes to this bug.