Bug 822130 - [abrt] hplip-3.12.2-4.fc16: setupdialog.py:659:showAddPrinterPage:NameError: global name 'PLUGIN_INSTALLED' is not defined
[abrt] hplip-3.12.2-4.fc16: setupdialog.py:659:showAddPrinterPage:NameError: ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:f9021b72d5999daef0815a21d4e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 08:37 EDT by Brittany Dunlap
Modified: 2012-05-16 13:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 13:08:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brittany Dunlap 2012-05-16 08:37:02 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/hp-setup
comment:        I'm running hp-setup to install/setup my wireless printer (HP LaserJet Professional p1102w).
executable:     /usr/bin/hp-setup
kernel:         3.3.5-2.fc16.x86_64
reason:         setupdialog.py:659:showAddPrinterPage:NameError: global name 'PLUGIN_INSTALLED' is not defined
time:           Wed 16 May 2012 08:32:32 AM EDT
uid:            1000
username:       brittany

backtrace:
:setupdialog.py:659:showAddPrinterPage:NameError: global name 'PLUGIN_INSTALLED' is not defined
:
:Traceback (most recent call last):
:  File "/usr/share/hplip/ui4/setupdialog.py", line 1255, in NextButton_clicked
:    self.showAddPrinterPage()
:  File "/usr/share/hplip/ui4/setupdialog.py", line 659, in showAddPrinterPage
:    if core.check_for_plugin() != PLUGIN_INSTALLED:
:NameError: global name 'PLUGIN_INSTALLED' is not defined
:
:Local variables in innermost frame:
:core: <installer.core_install.CoreInstall object at 0x3595710>
:self: <ui4.setupdialog.SetupDialog object at 0x33b6830>
:plugin_reason: 1
:plugin: 1

smolt_data:
:
:
:General
:=================================
:UUID: 8e92c498-772d-461e-90eb-9332c8e6fc33
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4388.83
:CPU Vendor: GenuineIntel
:CPU Model: Pentium(R) Dual-Core CPU       T4400  @ 2.20GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2200
:System Memory: 3916
:System Swap: 5951
:Vendor: Dell Inc.
:System: Inspiron 1750 
:Form factor: Portable
:Kernel: 3.3.5-2.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10816:4136:1030) pci, agpgart-intel, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10544:4136:1030) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10537:4136:1030) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10521:4136:1030) pci, None, PCI/ISA, ICH9M LPC Interface Controller
:(4523:17236:4136:1030) pci, sky2, ETHERNET, 88E8040 PCI-E Fast Ethernet Controller
:(32902:16930:32902:4096) pci, iwl3945, NETWORK, PRO/Wireless 3945ABG Network Connection
:(32902:9288:4136:1030) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10549:4136:1030) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:4136:1030) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:4136:1030) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4136:1030) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:4136:1030) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4136:1030) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10818:4136:1030) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10819:4136:1030) pci, None, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10560:4136:1030) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:4136:1030) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10568:4136:1030) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:4136:1030) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:4136:1030) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4136:1030) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(32902:10564:4136:1030) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_fedora-lv_root / ext4 4096 4096 13092922 12132226 12001189 3276800 3165452 3165452
:/dev/sda1 /boot ext4 1024 1024 508745 435234 409634 128016 127785 127785
:/dev/mapper/vg_fedora-lv_home /home ext4 4096 4096 63307897 62077951 58908876 15851520 15850926 15850926
:
Comment 2 Jiri Popelka 2012-05-16 10:04:28 EDT
Thanks for the report.

How did you install hplip ?
What do 'rpm -q hplip' and 'rpm -V hplip' say ?
Comment 3 Brittany Dunlap 2012-05-16 12:46:58 EDT
I installed hplip two ways since the first didn't work. through the .run file provided at hplipopensource.com and then through yum.

[brittany@fedora ~]$ rpm -q hplip
hplip-3.12.2-4.fc16.x86_64
[brittany@fedora ~]$ rpm -V hplip
..?......    /usr/lib/cups/backend/hpfax
S.5....T.    /var/lib/hp/hplip.state
Comment 4 Jiri Popelka 2012-05-16 13:08:14 EDT
That explains it. Your hplip installation seems to be in some "mixed" state.
I'm not sure how to fix it. Maybe:
yum remove hplip*
install the upstream provided file via .run
try to completely remove it with hp-uninstall (new since 3.12.4)
yum install hplip

If you want to report the not working hplip installed via the .run file, you can do that at https://bugs.launchpad.net/hplip

Closing.

Note You need to log in before you can comment on or make changes to this bug.