Bug 822139 - [RFE] Need Support for Rhel 6.3 JEOS image
Summary: [RFE] Need Support for Rhel 6.3 JEOS image
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: imagefactory   
(Show other bugs)
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
Assignee: Ian McLeod
QA Contact: Giulio Fidente
URL:
Whiteboard:
Keywords: FutureFeature, ZStream
Depends On:
Blocks: 831683
TreeView+ depends on / blocked
 
Reported: 2012-05-16 13:10 UTC by Shveta
Modified: 2012-12-04 15:09 UTC (History)
11 users (show)

Fixed In Version: imagefactory-1.0.2-1.el6cf
Doc Type: Enhancement
Doc Text:
Oz and Imagefactory were updated to include Red Hat Enterprise Linux (RHEL) 6.3. RHEL 6.3 was previously unsupported. RHEL 6.3 is now supported in CloudForms 1.1.
Story Points: ---
Clone Of:
: 831683 (view as bug list)
Environment:
Last Closed: 2012-12-04 15:09:41 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1516 normal SHIPPED_LIVE CloudForms Cloud Engine 1.1 update 2012-12-04 19:51:45 UTC

Description Shveta 2012-05-16 13:10:31 UTC
Description of problem: 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Build and Push for Rhel 6.3 is not supported as of now 

this is what i get in imagefactory.log

2012-05-16 05:17:15,586 DEBUG imgfac.BuildJob.BuildJob thread(bd4e50bd) Message: Builder (bd4e50bd-eeb3-455d-b7be-e7d130a2c38c) changed status from PUSHING to FAILED
2012-05-16 05:17:15,586 DEBUG imgfac.BuildJob.BuildJob thread(bd4e50bd) Message: bd4e50bd-eeb3-455d-b7be-e7d130a2c38c for ec2 about to exit ec2 queue...
2012-05-16 05:17:15,586 DEBUG imgfac.ReservationManager.ReservationManager thread(bd4e50bd) Message: EXITING queue: (ec2)
2012-05-16 05:17:15,586 DEBUG imgfac.ReservationManager.ReservationManager thread(bd4e50bd) Message: SUCCESS EXITING queue: (ec2)
2012-05-16 05:17:15,586 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder thread(bd4e50bd) Message: Exception caught in ImageFactory
2012-05-16 05:17:15,587 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder thread(bd4e50bd) Message: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/imgfac/builders/Fedora_ec2_Builder.py", line 458, in push_image
    credentials)
  File "/usr/lib/python2.6/site-packages/imgfac/builders/Fedora_ec2_Builder.py", line 580, in push_image_snapshot_ec2
    raise ImageFactoryException("No available JEOS for desired OS, verison combination")
ImageFactoryException: No available JEOS for desired OS, verison combination

2012-05-16 05:17:15,587 DEBUG imgfac.BuildJob.BuildJob thread(bd4e50bd) Message: Builder (bd4e50bd-eeb3-455d-b7be-e7d130a2c38c) changed status from FAILED to FAILED

2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ian McLeod 2012-06-13 14:40:17 UTC
This is blocked pending availability of the "final" RHEL 6.3 AMIs.  We are doing some internal testing using limited-availability beta AMIs.

I will update this BZ when 6.3 AMIs are available publicly.

Comment 2 Ian McLeod 2012-06-18 13:39:37 UTC
Updated oz and imagefactory packages are available in brew containing the RC1 AMIs for 6.3.

Comment 4 Ian McLeod 2012-09-11 23:01:18 UTC
Updated fix for this is currently brewing as imagefactory 1.0.2-1.

Comment 5 Giulio Fidente 2012-09-18 14:06:22 UTC
works for me as imagefactory-1.0.2-1.el6cf using public AMI ami-1f00016b

Comment 7 errata-xmlrpc 2012-12-04 15:09:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html


Note You need to log in before you can comment on or make changes to this bug.