Bug 822276 - geany-0.21-5.fc17 failed to build from source
geany-0.21-5.fc17 failed to build from source
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: geany (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-16 18:39 EDT by German Ruiz
Modified: 2012-09-01 16:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-01 16:46:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description German Ruiz 2012-05-16 18:39:43 EDT
geany failed to build on koji for fedora 17

the problem is that it needs gmodule-2.0 with the version of glib/gio 2.31

this patches[0] fix the problem with gmodules[1] and also add the m4 files that are not included in the fedora git repository

[0]patches
gmodule patch:
http://germanrs.fedorapeople.org/rpm/gmodule.patch
m4 patch:
http://germanrs.fedorapeople.org/rpm/m4.patch
geany spec:
http://germanrs.fedorapeople.org/rpm/geany.spec

[1] http://git.geany.org/geany/commit/?id=7b2f0fe5aef6c389738f4a861cc19dfec5ce2c42
Comment 1 Dominic Hopf 2012-09-01 16:46:57 EDT
The issue has been fixed with a patch in the 0.21 packages before (thanks to Peter Robinson). The fix is included upstream since Geany 1.22. I'm going to close this bug.

Note You need to log in before you can comment on or make changes to this bug.