Bug 822359 - catalog url for partner site should be https rather than http
catalog url for partner site should be https rather than http
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.5
Unspecified Linux
urgent Severity urgent
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-05-17 03:16 EDT by Guangze Bai
Modified: 2015-02-08 16:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:28:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalog and environment patch switching to https from http (1.81 KB, patch)
2012-05-17 12:00 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Guangze Bai 2012-05-17 03:16:42 EDT
Description of problem:

In /etc/v7.xml,

<catalog-url>https://partner-hwcert.redhat.com/xmlrpc.cgi</catalog-url>

but this makes a 302 error when opening with the url:
== snip ==
Error: could not open a new certification:
<ProtocolError for partner-hwcert.redhat.com/xmlrpc.cgi: 302 Found>

Version-Release number of selected component (if applicable):
v7-1.5-25

How reproducible:
always

Steps to Reproduce:
1. rm /etc/v7.xml
2. v7 plan and open a certification
3.
  
Expected results:
succeed opening/submiting a cert

Additional info:
This blocked catalog team, so mark this urgent. Please resolve this ASAP.
Comment 1 Guangze Bai 2012-05-17 03:18:59 EDT
(In reply to comment #0)
> Description of problem:
> 
> In /etc/v7.xml,
> 
> <catalog-url>https://partner-hwcert.redhat.com/xmlrpc.cgi</catalog-url>
> 

Oh, sorry, I want to say this wrong url:

<catalog-url>http://partner-hwcert.redhat.com/xmlrpc.cgi</catalog-url>
                ^^
Comment 3 Greg Nichols 2012-05-17 12:00:40 EDT
Created attachment 585262 [details]
catalog and environment patch switching to https from http

Added code in catalog.py to support manual protocol changes in v7.xml
Comment 7 Caspar Zhang 2012-06-04 04:07:54 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 9 errata-xmlrpc 2012-06-05 17:28:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.