Bug 822379 - [lpfc FCoE] lpfc FCoE cannot rescan newly added FCoE target.
[lpfc FCoE] lpfc FCoE cannot rescan newly added FCoE target.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Rob Evers
Bruno Goncalves
:
Depends On:
Blocks: 846704
  Show dependency treegraph
 
Reported: 2012-05-17 04:20 EDT by Gris Ge
Modified: 2016-03-15 07:18 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-15 06:58:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2012-05-17 04:20:01 EDT
Description of problem:

I create FCoE target on fcoe-target-utils via intel soft FCoE and map to lpfc FCoE card.

Rescan via sysfs cannot work:
====
echo "- - -" > /sys/class/scsi_host/host2/scan
====

As my server is boot from lpfc FCoE, I cannot reload lpfc kernel module.
After OS reboot, new LUN came out.


Version-Release number of selected component (if applicable):
kernel -272

How reproducible:
100%

Steps to Reproduce:
1. Use these commands to create FCoE target on intel CNA card. (not sure where add LUN on NetApp or other storage array trigger or not):
====
yum install fcoe-target-utils -y
service fcoe-target start
dd if=/dev/zero of=/tmp/fcoe-lun1 count=0 seek=10240 bs=1M
targetcli
/backstores/fileio create disk1 /tmp/fcoe-lun1 10240M

/tcm_fc/ create 20:00:00:1b:21:59:12:37
/tcm_fc/ create 20:00:00:1b:21:59:12:36
/tcm_fc/20:00:00:1b:21:59:12:36/luns/ create /backstores/fileio/disk1
/tcm_fc/20:00:00:1b:21:59:12:36/acls/ create 10:00:00:00:c9:e6:61:d1
/tcm_fc/20:00:00:1b:21:59:12:36/acls/ create 10:00:00:00:c9:e6:61:d5
/tcm_fc/20:00:00:1b:21:59:12:37/luns/ create /backstores/fileio/disk1
/tcm_fc/20:00:00:1b:21:59:12:37/acls/ create 10:00:00:00:c9:e6:61:d5
/tcm_fc/20:00:00:1b:21:59:12:37/acls/ create 10:00:00:00:c9:e6:61:d1
====

2. Rescan lpfc scsi_host
===
echo "- - -" > /sys/class/scsi_host/host2/scan
===
3.
  
Actual results:
No new LUN created.

Expected results:
New LUN created.

Additional info:

I am not sure whether lpfc FCoE support this feature or not.

lpfc FC card can add LUN online, didn't try "add FC target".

It's kind of late in RHEL 6.3, QE suggest postpone this bug to RHEL 6.4 unless manager or Emulex and it as blocker.
Comment 1 Gris Ge 2012-05-17 04:53:52 EDT
Confirmed RHEL 6.2 GA has the same problem. Not a regression.
Comment 2 Gris Ge 2012-05-17 05:23:09 EDT
If only adding LUN on exist FC target (FCoE switch perform FC/FCoE transaction), rescan works well.

Changing subject of this bug.
Comment 3 RHEL Product and Program Management 2012-07-10 03:30:40 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 19:42:10 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 RHEL Product and Program Management 2012-12-14 02:39:13 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Rob Evers 2015-11-09 16:23:00 EST
Can this be reproduced with rhel6.7?
Comment 7 Laurie Barry 2016-03-12 09:15:02 EST
Rob,

I recommend closing this bug due to lack of info/activity.

Laurie
Comment 8 Rob Evers 2016-03-14 16:09:23 EDT
Bruno, should we close this due to lack of information?
Comment 9 Bruno Goncalves 2016-03-15 06:58:52 EDT
Rob,

I think we can close this BZ, I've tried rhel-6.7 and the LUN was detected well after scanning the host adapter.

# modinfo lpfc
filename:       /lib/modules/2.6.32-573.el6.x86_64/kernel/drivers/scsi/lpfc/lpfc.ko
version:        0:10.6.0.20

Adapter information:

			[PN] Part number: BK835-63002
			[SN] Serial number: CN652006X0
			[V0] Vendor specific: WC52015523
			[EC] Engineering changes: A-5450
			[FN] Unknown: 36 34 39 31 30 38 2d 30 30 31
			[VA] Vendor specific: 5520
			[VB] Vendor specific: PW=11W; PCIE X8 GEN 2
			[V1] Vendor specific: HP CN1100E Dual Port Converged Network Adapter
			[V2] Vendor specific: CN1100E
			[V4] Vendor specific: 1
			[V5] Vendor specific: OCe11102-FX-HP
			[V6] Vendor specific: A0:1, D0:1
			[V7] Vendor specific: ID:0004,V:04.04.05.05
			[RV] Reserved: checksum good, 21 byte(s) reserved

Note You need to log in before you can comment on or make changes to this bug.