Bug 822392 - gdal doesn't build with poppler-0.20.0
gdal doesn't build with poppler-0.20.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdal (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Devrim GÜNDÜZ
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 04:49 EDT by Marek Kašík
Modified: 2012-05-20 17:12 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-20 17:12:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Kašík 2012-05-17 04:49:54 EDT
Description of problem:
gdal fails when built with new poppler-0.20.0.


Version-Release number of selected component (if applicable):
gdal-1.9.0-3


Additional info:
These patches should fix the problem:
http://trac.osgeo.org/gdal/changeset/23991
http://trac.osgeo.org/gdal/changeset/24415
Comment 1 Volker Fröhlich 2012-05-17 16:16:21 EDT
Thank you for looking at potential patches!

RC2 of GDAL 1.9.1 was published yesterday, which doesn't work with poppler 0.20 either. I contacted Even Rouault, who commited most changes to the PDF driver.

He said, there are a couple of changes, so I'll better wait for him:
http://trac.osgeo.org/gdal/ticket/4668

I'll therefore disable the GDAL PDF driver for now.
Comment 2 Volker Fröhlich 2012-05-20 17:12:27 EDT
It turned out, the backport was quickly done. Rawhide is fine again.

Note You need to log in before you can comment on or make changes to this bug.