Bug 822397 - The manual related to virt-v2v need be updated
The manual related to virt-v2v need be updated
Status: CLOSED DUPLICATE of bug 1017492
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 05:27 EDT by tingting zheng
Modified: 2014-06-12 09:33 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-12 09:33:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2012-05-17 05:27:42 EDT
Description of problem:
The manual related to v2v need be updated:there are some typos in virt-v2v manual and the timestamp of Copyright is not unified.

Version-Release number of selected component (if applicable):
virt-v2v-0.8.7-6.el6.x86_64

How reproducible:
Always.

Steps to Reproduce:
1.Typos in virt-v2v manual:
# man virt-v2v
If it is not possible to provide software updates over the network in your environment,
       software will be installed as specified in virt-v2v.conf. See virt-v2v.conf(5) for a details.

s/for a details/for details

2.Typos in other manuals:the brackets in the below manuals are not matched
Sys::VirtConvert::Connection::Source(3pm, virt-v2v(1), <http://libguestfs.org/>.
s/Source(3pm,/Source(3pm),

# man 3 Sys::VirtConvert::Config
Sys::VirtConvert::ConfUser)Contributed Perl DocumenSys::VirtConvert::Config(3)

# man 3 Sys::VirtConvert::Connection::Source
Sys::VirtConvert::ConnUseroContributed)Sys::VirtConvert::Connection::Source(3)

# man 3 Sys::VirtConvert::Connection::Volume
Sys::VirtConvert::ConnUseroContributed)Sys::VirtConvert::Connection::Volume(3)

# man 3 Sys::VirtConvert::Converter::Windows
Sys::VirtConvert::ConvUserrContributed)Sys::VirtConvert::Converter::Windows(3)


3.Check timestamp of Copyright in virt-v2v manual.
# man virt-v2v
……
COPYRIGHT
       Copyright (C) 2009-2011 Red Hat Inc.
……

4.Check some lib files, e.g.
# cat /usr/share/perl5/vendor_perl/Sys/VirtConvert.pm |grep Copyright
# Copyright (C) 2009-2011 Red Hat Inc.
Copyright (C) 2009-2011 Red Hat Inc.

# cat /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm |grep Copyright
# Copyright (C) 2009-2012 Red Hat Inc.
Copyright (C) 2009-2011 Red Hat Inc.

# cat /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/Windows.pm |grep Copyright
# Copyright (C) 2009-2011 Red Hat Inc.
Copyright (C) 2009-2011 Red Hat Inc.

5.Check Copyright in virt-p2v-server.
# cat /usr/bin/virt-p2v-server
#!/usr/bin/perl 

eval 'exec /usr/bin/perl  -S $0 ${1+"$@"}'
    if 0; # not running under some shell
# virt-p2v-server
# Copyright (C) 2011 Red Hat Inc.
……
Copyright (C) 2011 Red Hat Inc.

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.
……

Actual Results:
As mentioned in steps.

Expected results:
There are no typos in virt-v2v manual and the timestamp of Copyright is unified and updated to the latest time.

Additional info:
Comment 2 Matthew Booth 2012-05-17 09:34:42 EDT
Issue 1 is fixed upstream in 0e3dca9b073e2abfc10c0f6394cce17b0138d8ef.
Issues 3, 4 and 5 are fixed upstream in 89828a01eed4a8073f0947838d53b3b4f4b568b0.

I don't understand issue 2 yet.
Comment 3 RHEL Product and Program Management 2012-05-21 02:48:32 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 tingting zheng 2012-05-21 04:45:47 EDT
(In reply to comment #2)
> Issue 1 is fixed upstream in 0e3dca9b073e2abfc10c0f6394cce17b0138d8ef.
> Issues 3, 4 and 5 are fixed upstream in
> 89828a01eed4a8073f0947838d53b3b4f4b568b0.
> 
> I don't understand issue 2 yet.

For issue 2,the brackets in the below manuals are not matched
I missed one command,it should be:
# man 3 Sys::VirtConvert::Connection::LibVirtXMLSource
Sys::VirtConvert::Connection::Source(3pm, virt-v2v(1), <http://libguestfs.org/>.
s/Source(3pm,/Source(3pm)

# man 3 Sys::VirtConvert::Config
Sys::VirtConvert::ConfUser)Contributed Perl DocumenSys::VirtConvert::Config(3)

# man 3 Sys::VirtConvert::Connection::Source
Sys::VirtConvert::ConnUseroContributed)Sys::VirtConvert::Connection::Source(3)

# man 3 Sys::VirtConvert::Connection::Volume
Sys::VirtConvert::ConnUseroContributed)Sys::VirtConvert::Connection::Volume(3)

# man 3 Sys::VirtConvert::Converter::Windows
Sys::VirtConvert::ConvUserrContributed)Sys::VirtConvert::Converter::Windows(3)
Comment 5 Jan Chaloupka 2014-06-12 09:33:12 EDT
Issue #2 is not a man-page issue. Rather problem of displaying the man page on RHEL6.6. Not the only issue.

Displaying page on Fedora displays correct header.

*** This bug has been marked as a duplicate of bug 1017492 ***

Note You need to log in before you can comment on or make changes to this bug.