Bug 822415 - mkdumprd doesn't need to pass mount nfs option to dracut
mkdumprd doesn't need to pass mount nfs option to dracut
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Baoquan He
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 822416
  Show dependency treegraph
 
Reported: 2012-05-17 05:55 EDT by WANG Chao
Modified: 2013-05-27 02:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 822416 (view as bug list)
Environment:
Last Closed: 2013-05-27 02:08:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description WANG Chao 2012-05-17 05:55:47 EDT
Description of problem:
When configuring to dump to a nfs server, currently mkdumprd pass '--mount nfs.server.com:/mnt/testarea/nfs/' to dracut to build kdump image. And dracut will write that mount option to image's fstab, then in second kernel, dracut will try to mount nfs server regarding to the fstab.
This is not necessary, because dracut-kdump.sh will mount the nfs server itself.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Configure nfs dump
2.restart kdump service
3.crash the system
  
Actual results:
dracut will try to mount the nfs server, and later kdump will do the same

Expected results:
Only kdump mount the nfs-server.

Additional info:
Comment 1 Fedora Admin XMLRPC Client 2013-02-25 03:07:08 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.