Bug 822437 - add channel ID to all GSpice-DEBUG connection-related messages
add channel ID to all GSpice-DEBUG connection-related messages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: beta
: 6.4
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 06:48 EDT by David Jaša
Modified: 2013-02-21 03:47 EST (History)
5 users (show)

See Also:
Fixed In Version: spice-gtk-0.14-1.el6
Doc Type: Bug Fix
Doc Text:
No doc needed (improvements in debug logs)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:47:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-05-17 06:48:27 EDT
Description of problem:
add channel ID to all GSpice-DEBUG connection-related messages. While some messages from spice-channel.c contain channel ID:
spice-channel.c:1664 main-1:0: spice_channel_recv_link_msg: 2 caps
                                   ^^^^^^^^

many others in spice-channel.c and spice-session.c do not:

spice-channel.c:2238 Open coroutine starting 0x1e51080
spice-channel.c:2090 Started background coroutine 0x1e51108 for usbredir-9:0
GSpice-DEBUG: spice-session.c:1520 Resolving host 127.0.0.1 5800
spice-session.c:1533 Trying one socket
spice-session.c:1482 Socket pending
spice-channel.c:2238 Open coroutine starting 0x1e53480
spice-channel.c:2090 Started background coroutine 0x1e53508 for inputs-3:0
spice-session.c:1520 Resolving host 127.0.0.1 5800
spice-session.c:1533 Trying one socket
spice-session.c:1482 Socket pending
spice-session.c:1497 Finally connected
spice-session.c:1497 Finally connected

Which of "Finally connected" messages belong to what channel?


Version-Release number of selected component (if applicable):
spice-gtk-0.11-9.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. run spice-gtk-based client with spice debug enabled
2.
3.
  
Actual results:
connection/channel related messages do not distinguish between channels

Expected results:
connection/channel related messages contain channel ID of channel concerned

Additional info:
Comment 1 RHEL Product and Program Management 2012-07-10 02:55:53 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 22:00:24 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Christophe Fergeau 2012-09-14 11:14:43 EDT
This is fixed by http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=80470049224ebea60403dfb526feab7b5514d0d3 This prints the channel name and not its ID though, dunno if this is what was meant in this bug report.
Comment 5 David Jaša 2012-09-14 11:24:11 EDT
The best would be both but in general, names are more useful than IDs, so IMO that's good enough.
Comment 9 errata-xmlrpc 2013-02-21 03:47:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0343.html

Note You need to log in before you can comment on or make changes to this bug.