Bug 822451 - [RHEVM] [backend] host does not become non-operational when its interface from cluster network goes down
[RHEVM] [backend] host does not become non-operational when its interface fro...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Moti Asayag
Martin Pavlik
network
: Regression
: 840438 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 07:35 EDT by Martin Pavlik
Modified: 2016-02-10 14:47 EST (History)
7 users (show)

See Also:
Fixed In Version: si12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (77.06 KB, application/x-gzip)
2012-05-17 07:38 EDT, Martin Pavlik
no flags Details
configuration of tested LN (151.09 KB, image/png)
2012-05-17 07:39 EDT, Martin Pavlik
no flags Details
host is up / NIC is seen as down (159.82 KB, image/png)
2012-05-17 07:39 EDT, Martin Pavlik
no flags Details
vdsm.log + engine.log second attempt (98.21 KB, application/x-gzip)
2012-06-04 04:25 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-05-17 07:35:40 EDT
Description of problem:
If an interface(other than rhevm) which is assigned to logical network goes down, host does not become non operational (waited for hour or so, tested more then once), in webadmin it is possible to see that affected interface is seen as down

Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-9.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. Create new logical network
2. Assign the network to the host NIC
3. Activate the host
4. ssh/console to the host and run ifdown on logical network bridge and its physical interface (i.e. ifdown NET1 && ifdown em2)
  
Actual results:
Host remains operation when it has interface from cluster network down

Expected results:
Host remains operation when it has interface from cluster network down

Additional info:
I tried also to unplug network cable from the switch to simulate this problem result was same
Comment 1 Martin Pavlik 2012-05-17 07:38:40 EDT
Created attachment 585195 [details]
vdsm.log + engine.log
Comment 2 Martin Pavlik 2012-05-17 07:39:14 EDT
Created attachment 585196 [details]
configuration of tested LN
Comment 3 Martin Pavlik 2012-05-17 07:39:58 EDT
Created attachment 585197 [details]
host is up / NIC is seen as down
Comment 4 Martin Pavlik 2012-05-17 07:44:35 EDT
Update to comment 1

Expected result:

Host becomes non-operational when it has interface from cluster network goes down
Comment 5 Martin Pavlik 2012-05-18 04:55:47 EDT
Interface operational status after ifdowns

cat /sys/class/net/em2/operstate 
down



Network was added as "required" (see http://lists.ovirt.org/wiki/Features/Design/Network/Required_Networks)
Comment 6 lpeer 2012-06-03 06:34:32 EDT
Hi Martin, Is the network a required network? by default it is non-required and thus the host should not moved to non-operational.

Please note that a audit log message should be issued
Comment 7 Martin Pavlik 2012-06-04 04:24:45 EDT
Hi Livnat, yes network was added as required (see comment 5)

has default behavior for required network change recently?
in my version oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-11.el6ev 

clusters -> your cluster -> Logical Networks -> Add Network will add new network as required (verified in DB)

To make sure I reproduced the scenario again and attached logs.
Comment 8 Martin Pavlik 2012-06-04 04:25:21 EDT
Created attachment 589068 [details]
vdsm.log + engine.log second attempt
Comment 10 Avi Tal 2012-07-16 09:26:46 EDT
*** Bug 840438 has been marked as a duplicate of this bug. ***
Comment 11 Avi Tal 2012-07-16 09:28:18 EDT
BZ#840438 reproduce this issue with rhevm 3.1 and cluster 3.0.
Comment 12 Moti Asayag 2012-07-23 16:38:35 EDT
A suggested patch:

http://gerrit.ovirt.org/#/c/6557
Comment 13 Moti Asayag 2012-07-24 02:30:38 EDT
commit-id 8be0ab769a6b9066e0201c3ed678873be25b6b98

Note You need to log in before you can comment on or make changes to this bug.