Bug 822456 - g++: Internal error: Killed (program cc1plus) durring LibreOffice build
g++: Internal error: Killed (program cc1plus) durring LibreOffice build
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gcc (Show other bugs)
6.3
s390x Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 07:52 EDT by Tomas Pelka
Modified: 2012-05-17 07:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-17 07:57:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build log (121 bytes, text/plain)
2012-05-17 07:52 EDT, Tomas Pelka
no flags Details

  None (edit)
Description Tomas Pelka 2012-05-17 07:52:02 EDT
Created attachment 585198 [details]
build log

Description of problem:
full log at http://nest.test.redhat.com/mnt/qa/scratch/ibm-z10-13/2012:12592/tps/libreoffice-3.4.5.2-14.el6.src.rpm-s390x-rebuild.log

Version-Release number of selected component (if applicable):
gcc-gfortran-4.4.6-4.el6.s390x
libgcc-4.4.6-4.el6.s390x
gcc-4.4.6-4.el6.s390x
gcc-c++-4.4.6-4.el6.s390x
gcc-java-4.4.6-4.el6.s390x

How reproducible:
100%

Steps to Reproduce:
1. rpmbuild --rebuild   --define "dist .el6" --define '_topdir /usr/src/redhat' --target=s390x --rcfile /tmp/tps_rpmrc_U0tdgV /mnt/redhat/brewroot/packages/libreoffice/3.4.5.2/14.el6/data/signed/fd431d51/src/libreoffice-3.4.5.2-14.el6.src.rpm
2.
3.
  
Actual results:
-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/src/redhat/BUILD/libreoffice-3.4.5.2/sal/qa/OStringBuffer

 it seems that the error is inside 'sal', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

Expected results:
should be builded

Additional info:
Comment 1 Jakub Jelinek 2012-05-17 07:57:20 EDT
Just retry, killed means OOM kill, which could very well be because multiple memory hungry builds were scheduled at the same time on the same box, or it has too few memory.  Nothing gcc can do about it, unless you get the same each time on the same source and gcc is unreasonable amounts of RAM compared to the input.

Note You need to log in before you can comment on or make changes to this bug.