Bug 822586 - startd can be blocked by external script
startd can be blocked by external script
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
2.2
Unspecified Unspecified
medium Severity medium
: 2.2
: ---
Assigned To: Timothy St. Clair
MRG Quality Engineering
:
Depends On:
Blocks: 591521 825580
  Show dependency treegraph
 
Reported: 2012-05-17 11:13 EDT by Lubos Trilety
Modified: 2013-01-04 10:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-23 14:20:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Trilety 2012-05-17 11:13:04 EDT
Description of problem:
If the script used in MACHINE_RESOURCE_INVENTORY_railgun = /path/to/script.sh never ends it blocks startd completely, because there's no time out.

Version-Release number of selected component (if applicable):
condor-7.6.8-0.1

How reproducible:
100%

Steps to Reproduce:
1. put 'MACHINE_RESOURCE_INVENTORY_railgun = /path/to/script.sh' to config
where script.sh looks like

#!/bin/sh
echo "DetectedRailgun = 8
while true; do sleep 1; done

2. start condor
  
Actual results:
No error message in logs and startd waits until the script ends.

Expected results:
Startd prints some error message and eventually ends

Additional info:

Note You need to log in before you can comment on or make changes to this bug.