Bug 822594 - [6.4 FEAT] SELinux updates for QEMU sandboxing with seccomp
[6.4 FEAT] SELinux updates for QEMU sandboxing with seccomp
Status: CLOSED DUPLICATE of bug 822593
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
All All
unspecified Severity medium
: rc
: 6.4
Assigned To: Paul Moore
Virtualization Bugs
: FutureFeature
Depends On:
Blocks: 745944
  Show dependency treegraph
 
Reported: 2012-05-17 11:22 EDT by IBM Bug Proxy
Modified: 2012-08-21 11:43 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 14:56:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 73755 None None None Never

  None (edit)
Description IBM Bug Proxy 2012-05-17 11:22:18 EDT
1. Feature Overview:
Feature Id: [73755]
a. Name of Feature: [6.4 FEAT] SELinux updates for QEMU sandboxing with seccomp
b. Feature Description

This feature will provide any required SELinux policy support on top of QEMU seccomp sandboxing support.

QEMU support will be provided to limit QEMU to only the system calls that it
requires.  New seccomp Kernel functionality is intended to be used to declare
the whitelisted syscalls and syscall parameters.  This will limit QEMU's
syscall footprint, and therefore the potential Kernel attack surface.  The idea
is that if an attacker were to execute abitrary code, they would only be able
to use the whitelisted syscalls.

2. Feature Details:
Sponsor: LTC Security
Architectures:  

Arch Specificity: both
Affects Kernel Modules: No
Delivery Mechanism: Direct from Community
Category: other
Request Type: Package - Version Update
d. Upstream Acceptance: Not Started
Sponsor Priority P2
f. Severity: normal
IBM Confidential: No
Code Contribution: unsure
g. Component Version Target: ---

3. Business Case
This feature will further increase the security of the KVM hypervisor by tightening QEMU's SELinux policy in addition to the limiting the potential Kernel attack surface within QEMU.

4. Primary contact at Red Hat:
John Jarvis, jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie A. Glass, sglass@us.ibm.com

Technical contact(s):
Corey C. Bryant, bryntcor@us.ibm.com
Comment 2 Paul Moore 2012-05-21 12:42:59 EDT
The QEMU sandboxing effort with seccomp should not require any SELinux policy modifications to function.  If any changes are necessary they should be treated as bugs against the sandboxing code and/or SELinux policy.

I think the best approach here is to close this feature request and track any issues that arise directly in BZ 822593.  Let me know if you have any concerns about closing this request.
Comment 3 IBM Bug Proxy 2012-05-21 13:10:27 EDT
------- Comment From bryntcor@us.ibm.com 2012-05-21 17:07 EDT-------
(In reply to comment #5)
> The QEMU sandboxing effort with seccomp should not require any SELinux
> policy modifications to function.  If any changes are necessary they should
> be treated as bugs against the sandboxing code and/or SELinux policy.
>
> I think the best approach here is to close this feature request and track
> any issues that arise directly in BZ 822593.  Let me know if you have any
> concerns about closing this request.

I agree, this BZ can be closed.
Comment 4 Paul Moore 2012-05-21 14:56:35 EDT

*** This bug has been marked as a duplicate of bug 822593 ***

Note You need to log in before you can comment on or make changes to this bug.