Bug 822671 - Test case failure: katello-configure Attempt to reconfigure SAM
Test case failure: katello-configure Attempt to reconfigure SAM
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello-configure (Show other bugs)
1.0.0
Unspecified Linux
high Severity high
: rc
: 1.X
Assigned To: Eric Sammons
SAM QE List
: Triaged
Depends On:
Blocks: 822927
  Show dependency treegraph
 
Reported: 2012-05-17 14:12 EDT by Eric Sammons
Modified: 2012-06-20 11:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
katello-configure would not exit after detecting an existing SAM environment, which resulted in environment reconfiguration. This update exits from katello-configure upon detection of an existing SAM environment. This avoids re-configuration.
Story Points: ---
Clone Of:
: 822927 (view as bug list)
Environment:
Last Closed: 2012-06-20 11:20:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1021 normal SHIPPED_LIVE Subscription Asset Manager 1.1 bug fix and enhancement update 2012-06-20 11:49:42 EDT

  None (edit)
Description Eric Sammons 2012-05-17 14:12:53 EDT
https://tcms.engineering.redhat.com/case/166528/?from_plan=5985

Version-Release number of selected component (if applicable):
2012-05-16.2
katello-common-0.3.1-1.el6_2.noarch
katello-cli-common-0.3.2-3.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
thumbslug-0.0.24-1.el6_2.noarch
katello-glue-candlepin-0.3.1-1.el6_2.noarch
katello-cli-headpin-0.2.0-1.el6_2.noarch
katello-certs-tools-1.1.5-1.el6_2.noarch
katello-configure-0.3.3-2.el6_2.noarch
katello-headpin-0.2.6-4.el6_2.noarch
candlepin-0.6.2-1.el6_2.noarch
candlepin-tomcat6-0.6.2-1.el6_2.noarch
katello-selinux-0.2.4-1.el6_2.noarch
katello-headpin-all-0.2.6-4.el6_2.noarch


Steps to Reproduce: 
SAM installed and configured


 1. As root or with root privileges run.
    # katello-configure --deployment=sam



Actual results: 
# katello-configure --deployment=sam
WARNING: Katello was already configured, reconfiguration is NOT supported yet
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20120517-141023/main.log]
[root@pinky ~]# headpin -u admin -p admin product list --org ACME_Corporation
Invalid oauth consumer or secret


Expected results:
WARNING: Katello was already configured, reconfiguration is NOT supported
Comment 1 Eric Sammons 2012-05-18 10:31:02 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: d379867b0b5ad0edb3f85287e0946d205ec42d62
     
https://github.com/Katello/katello/commit/d379867b0b5ad0edb3f85287e0946d205ec42d62
  Author: Eric Sammons <esammons@redhat.com>
  Date:   2012-05-18 

Missing exit_with after returning warning message.
Comment 2 Eric Sammons 2012-05-23 10:20:05 EDT
katello-configure-0.3.6-1.el6_2.noarch

# katello-configure --deployment=sam
WARNING: Katello was already configured, reconfiguration is NOT supported yet
# headpin -u admin -p admin shell
sam> org list
--------------------------------------------------------------------------------
                              Organization List

 Id   Name               Description                    
--------------------------------------------------------------------------------
 1    ACME_Corporation   ACME_Corporation Organization  
sam>

VERIFIED
Comment 3 sachua 2012-06-14 02:33:50 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When user runs the command: 
#katello-configure --deployment=sam
after SAM is installed and configured, katello-configure attempts to re-configure SAM. This update prevents katello-configure from re-configuring and user will see a warning message: WARNING: Katello was already configured, reconfiguration is NOT supported yet.
Comment 4 Dan Macpherson 2012-06-15 02:24:43 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,3 +1 @@
-When user runs the command: 
+katello-configure did not stop after detecting an existing SAM environment, which resulted in reconfiguration of the environment. This update exits from katello-configure upon detection of an existing SAM environment and avoids re-configuration.-#katello-configure --deployment=sam
-after SAM is installed and configured, katello-configure attempts to re-configure SAM. This update prevents katello-configure from re-configuring and user will see a warning message: WARNING: Katello was already configured, reconfiguration is NOT supported yet.
Comment 5 Dan Macpherson 2012-06-15 02:25:35 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-katello-configure did not stop after detecting an existing SAM environment, which resulted in reconfiguration of the environment. This update exits from katello-configure upon detection of an existing SAM environment and avoids re-configuration.+katello-configure would not exit after detecting an existing SAM environment, which resulted in environment reconfiguration. This update exits from katello-configure upon detection of an existing SAM environment. This avoids re-configuration.
Comment 7 errata-xmlrpc 2012-06-20 11:20:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1021.html

Note You need to log in before you can comment on or make changes to this bug.