Bug 82274 - Bluecurve bug gtk 2.2 - menubar
Bluecurve bug gtk 2.2 - menubar
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gtk2-engines (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-20 14:13 EST by Gines Razanov
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 14:21:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gines Razanov 2003-01-20 14:13:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; .NET 
CLR 1.0.3705)

Description of problem:
With GTK 2.2 installed the Bluecurve engine doesn't show the 3D effect of the 
menubar on GTK2 apps. (I have to reinstall Bluecurve engine after GTK 2.2)

With GTK 2.0 everything was fine

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install GTK 2.2
2.Re install Bluecurve engine
3.Apply theme on gnome
    

Actual Results:  The 3D effect on menu bar doesn't work on gtk2 apps, on gtk1 
apps looks good

Expected Results:  Have 3D effect like when I have gtk 2.0

Additional info:
Comment 1 Owen Taylor 2003-01-20 14:44:41 EST
I think this is working as intended. There isn't supposed to be a 3D
bevel for the menu. 
Comment 2 Gines Razanov 2003-01-20 14:51:53 EST
My english is quite bad, sorry
What I wanted to explain is that when I point the mouse to the menu, the 
selection bar has a 3D bevel on gtk1 and gtk2, (a blue bar with 3D bevel when 
you point the mouse to an option in the menu) but after upgrade to GTK 2.2 the 
bevel is not there only on gtk2 apps of course
I hope I make my self clear, if not I can't put a screenshot
Comment 3 Owen Taylor 2003-01-20 17:06:28 EST
Works fine for me. Are you sure you have the Bluecurve engine installed
correctly?
Comment 4 Gines Razanov 2003-01-21 07:59:19 EST
I was working fine for me too with gtk 2.0.x, but after upgrade to gtk 2.2 it 
does not work any more, I also have reinstalled the Bluecurve engine (rpm) 
again after the upgrade (twice) but the effect is not working any more(only on 
gtk2 apps), on gtk1 apps it still working fine.
Comment 5 Owen Taylor 2003-01-21 11:22:57 EST
I suspect that you don't have a gtk-engines that is built with
the right paths for gtk+-2.2.0. You are probably getting warnings
something like:

 *** Cannot find the engine 'libbluecurve.so' in path

from every GTK+ program.
Comment 6 Gines Razanov 2003-01-21 12:24:05 EST
No warnings, everything looks good
I have posted two screenshots to see what I mean
If you have time take a look at them
http://www.barilochejoven.com.ar/temp/shot.htm
I made two screenshots, one with a gtk1 app and the other with a gtk2 app, you 
will see the difference
Comment 7 Owen Taylor 2003-01-21 14:21:07 EST
Oh, you probably are using an old version of Bluecurve; GTK+-2.2 defaults
to no-bevel for menus, so you need a version of Bluecurve that turns
on the bevel. THe version of Bleucurve in Rawhide works properly 
with GTK+-2.2.


Comment 8 Gines Razanov 2003-01-21 14:30:40 EST
Where I can download an updated version?
Or tell me what version should I have to look for
Thank you very much, I really appreciate your help
Comment 9 Owen Taylor 2003-01-21 17:08:07 EST
"Rawhide" - ftp.redhat.com:/pub/redhat/linux/rawhide/ is usually the
best place to look for development versions of Red Hat package. 
(Caveat emptor ... what's there is frequently highly unstable.)
Comment 10 Gines Razanov 2003-01-21 19:39:10 EST
Everything looks beautiful again
Thanks :)

Note You need to log in before you can comment on or make changes to this bug.