Bug 822763 - [kde] system tray Icon need update needed to match with gnome
[kde] system tray Icon need update needed to match with gnome
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 01:07 EDT by A S Alam
Modified: 2013-07-02 21:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 06:25:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ibus icon in KDE (65.25 KB, image/png)
2012-05-18 01:07 EDT, A S Alam
no flags Details

  None (edit)
Description A S Alam 2012-05-18 01:07:41 EDT
Created attachment 585335 [details]
ibus icon in KDE

Description of problem:
KDE using old ibus icon in system tray setting. It can be upgrade.

Version-Release number of selected component (if applicable):
ibus-1.4.99.20120428-1.fc17.x86_64
kde-baseapps-4.8.3-1.fc17.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Enable Ibus
2. Right Click on System Tray
3. System Tray Settings->Entries
4. Check ibus icon
  
Actual results:
it is old icon

Expected results:
can be changed to match with gnome

Additional info:
Comment 1 fujiwara 2012-05-18 04:30:29 EDT
Why do you think it's an old icon?
I think it's the same with the icon on im-chooser.
Probably I think it's not a bug.
Comment 2 A S Alam 2012-05-18 05:35:24 EDT
(In reply to comment #1)
> Why do you think it's an old icon?
it was mistake, it is not old (http://code.google.com/p/ibus/)

> I think it's the same with the icon on im-chooser.
> Probably I think it's not a bug.

yes it is same as im-chooser, but different from Gnome look. Also different from what I got in KDE system-tray. Don't you think that icon should be same in KDE system tray and System tray setting? (It can be same in im-chooser and gnome-shell also).
Comment 3 fujiwara 2012-05-18 06:25:57 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > Why do you think it's an old icon?
> it was mistake, it is not old (http://code.google.com/p/ibus/)
> 
> > I think it's the same with the icon on im-chooser.
> > Probably I think it's not a bug.
> 
> yes it is same as im-chooser, but different from Gnome look. Also different
> from what I got in KDE system-tray. Don't you think that icon should be same in
> KDE system tray and System tray setting? (It can be same in im-chooser and
> gnome-shell also).

I'm not sure what you mean in GNOME look but probably I guess it's the icon on system-tray.

The system-tray icon is the default IME status and it's good to show the keyboard now.
But if ibus is referred, I think the issued icon is right.

% rpm -ql ibus | grep svg
/usr/share/icons/hicolor/scalable/apps/ibus-engine.svg
/usr/share/icons/hicolor/scalable/apps/ibus-keyboard.svg
/usr/share/icons/hicolor/scalable/apps/ibus-setup.svg
/usr/share/icons/hicolor/scalable/apps/ibus.svg

If you show the about dialog from ibus status icon, it shows the same icon.

Note You need to log in before you can comment on or make changes to this bug.