Bug 822764 - [abrt] yum-3.4.3-23.fc17: optparse.py:1602:print_usage:UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 195: ordinal not in range(128)
[abrt] yum-3.4.3-23.fc17: optparse.py:1602:print_usage:UnicodeEncodeError: 'a...
Status: CLOSED DUPLICATE of bug 819229
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:dc3b68f90307c35ee938d16e6e6...
:
: 1071486 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 01:26 EDT by Guillaume Poirier-Morency
Modified: 2014-03-03 06:30 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 04:04:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Guillaume Poirier-Morency 2012-05-18 01:26:25 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available --re
event_log:      2012-05-18-01:26:09> Smolt profile successfully saved
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.3.4-3.fc17.x86_64
time:           mer 09 mai 2012 13:29:38 EDT
uid:            1000
username:       guillaume

backtrace:
:optparse.py:1602:print_usage:UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 195: ordinal not in range(128)
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 81, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 75, in main
:    base.getOptionsConfig(args)
:  File "/usr/share/yum-cli/cli.py", line 287, in getOptionsConfig
:    (opts, self.cmds) = self.optparser.setupYumConfig(args=args)
:  File "/usr/share/yum-cli/cli.py", line 1903, in setupYumConfig
:    (opts, cmds) = self.parse_args(args=args)
:  File "/usr/lib64/python2.7/optparse.py", line 1399, in parse_args
:    stop = self._process_args(largs, rargs, values)
:  File "/usr/lib64/python2.7/optparse.py", line 1439, in _process_args
:    self._process_long_opt(rargs, values)
:  File "/usr/lib64/python2.7/optparse.py", line 1498, in _process_long_opt
:    self.error(_("%s option requires an argument") % opt)
:  File "/usr/share/yum-cli/cli.py", line 1853, in error
:    self.print_usage()
:  File "/usr/lib64/python2.7/optparse.py", line 1602, in print_usage
:    print >>file, self.get_usage()
:UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 195: ordinal not in range(128)
:
:Local variables in innermost frame:
:self: <cli.YumOptionParser instance at 0x11027e8>
:file: None

smolt_data:
:
:
:Général
:=================================
:UUID: 5c3898b2-3b97-4b75-975d-f5b27022d554
:SE: Fedora release 17 (Beefy Miracle)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_CA.utf8
:Plateforme: x86_64
:BogoMIPS: 5999.16
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM)2 Extreme CPU X9650  @ 3.00GHz
:Stepping du processeur: 7
:Famille de processeur: 6
:Modèle du processeur: 23
:Nombre de processeurs: 4
:Vitesse du processeur: 3000
:Mémoire du système: 7986
:Swap du système: 997
:Fabricant: Gigabyte Technology Co., Ltd.
:Système: X38-DQ6 
:Type d'ordinateur: Desktop
:Noyau: 3.3.4-5.fc17.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Terra.1680.1050
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(32902:10729:5208:20480) pci, pcieport, PCI/PCI, 82X38/X48 Express Host-Secondary PCI Express Bridge
:(32902:10720:5208:20480) pci, x38_edac, HOST/PCI, 82X38/X48 Express DRAM Controller
:(32902:10721:5208:20480) pci, pcieport, PCI/PCI, 82X38/X48 Express Host-Primary PCI Express Bridge
:(6164:1921:4163:4879) pci, rt2800pci, NETWORK, RT2860
:(32902:10544:5208:20481) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10528:5208:45058) pci, ata_piix, STORAGE, 82801IR/IO/IH (ICH9R/DO/DH) 4 port SATA IDE Controller
:(32902:10518:5208:20481) pci, None, PCI/ISA, 82801IR (ICH9R) LPC Interface Controller
:(32902:10534:5208:45058) pci, ata_piix, STORAGE, 82801I (ICH9 Family) 2 port SATA IDE Controller
:(32902:9294:5208:20480) pci, None, PCI/PCI, GA-EP45-DS5 Motherboard
:(32902:10549:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:5208:20486) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:5208:20486) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(5361:34898:112:30993) pci, cx23885, MULTIMEDIA_VIDEO, CX23885 PCI Video and Audio Decoder
:(32902:10564:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:10566:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10560:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10568:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:5208:40994) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:(32902:10551:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:5208:20484) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4318:1557:6618:4355) pci, nvidia, VIDEO, G92 [GeForce GTS 250]
:(32902:10570:5208:20481) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 6
:(4172:32804:5208:4096) pci, firewire_ohci, FIREWIRE, GA-EP45-DS5 Motherboard
:(6523:9059:5208:45056) pci, pata_jmicron, STORAGE, GA-EP45-DS5 Motherboard
:(6523:9059:5208:45056) pci, ahci, STORAGE, GA-EP45-DS5 Motherboard
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 4874987 1439316 1390500 1220608 901804 901804
:/dev/sdb WITHHELD ext4 4096 4096 487910848 435050580 410631648 122101760 122048481 122048481
:/dev/sda2 /home ext4 4096 4096 14372248 5339396 4619443 3604480 3213028 3213028
:/dev/sdc1 WITHHELD ext4 4096 4096 3895953 3677773 3482305 979200 967940 967940
:
Comment 1 Zdeněk Pavlas 2012-05-18 04:04:53 EDT

*** This bug has been marked as a duplicate of bug 819229 ***
Comment 2 Valentina Mukhamedzhanova 2014-03-03 06:30:34 EST
*** Bug 1071486 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.