Bug 822904 - Files with the same name can co-exist in single mounted volume
Files with the same name can co-exist in single mounted volume
Status: CLOSED WORKSFORME
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Divya
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 09:17 EDT by pushpesh sharma
Modified: 2014-08-04 18:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 03:09:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pushpesh sharma 2012-05-18 09:17:44 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
@dhcp201-104.englab.pnq.redhat.com (say node1) issue following cmds
1.gluster volume create test2 dhcp201-175.englab.pnq.redhat.com:/tmp/test2 dhcp201-175.englab.pnq.redhat.com:/tmp/test3
2.gluster volume start test2
3. mount -t glusterfs localhost:test2 /mnt/test2
4.cat /etc/profile >>/mnt/test2/quotatest

@  dhcp201-175.englab.pnq.redhat.com (say node2) issue following cmds

5. cp /tmp/test2/quotatest /tmp/test3/

@dhcp201-104.englab.pnq.redhat.com (say node1) issue following cmds

6. [root@dhcp201-104 ~]# ls /mnt/test2
quotatest  quotatest

[root@dhcp201-104 ~]# mv /mnt/test2/quotatest /mnt/test2/quotates
mv: cannot move `/mnt/test2/quotatest' to `/mnt/test2/quotates': File exists


Actual results:

Expected results:


It should not get in this situation although it a corner case but it might lead to some dataloss.


[root@dhcp201-104 ~]# rpm -qa|grep glusterfs-*
Binary file glusterfs-3.3.0beta4-1.x86_64.rpm matches
Binary file glusterfs-debuginfo-3.3.0beta4-1.x86_64.rpm matches
Binary file glusterfs-devel-3.3.0beta4-1.x86_64.rpm matches
Binary file glusterfs-fuse-3.3.0beta4-1.x86_64.rpm matches
Binary file glusterfs-geo-replication-3.3.0beta4-1.x86_64.rpm matches
Binary file glusterfs-rdma-3.3.0beta4-1.x86_64.rpm matches
Binary file glusterfs-server-3.3.0beta4-1.x86_64.rpm matches 
Additional info:
Comment 2 Vijay Bellur 2012-05-30 00:49:50 EDT
(In reply to comment #0)
> Description of problem:
> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> @dhcp201-104.englab.pnq.redhat.com (say node1) issue following cmds
> 1.gluster volume create test2 dhcp201-175.englab.pnq.redhat.com:/tmp/test2
> dhcp201-175.englab.pnq.redhat.com:/tmp/test3
> 2.gluster volume start test2
> 3. mount -t glusterfs localhost:test2 /mnt/test2
> 4.cat /etc/profile >>/mnt/test2/quotatest
> 
> @  dhcp201-175.englab.pnq.redhat.com (say node2) issue following cmds
> 
> 5. cp /tmp/test2/quotatest /tmp/test3/

Please note we do not support creation of data directly on the backend disk file system. All updates to a gluster volume should happen from a mountpoint. Since the  operation is not supported, this bug can be low priority or even CLOSED as we don't intend supporting this in the near future.
Comment 3 pushpesh sharma 2012-05-30 01:15:51 EDT
It will be good if it gets some place in documentation as "How not to use Gluster volumes".
Even it would be good if we can stop file operation from backend disk with a message like "This volume is marked as gluster volume,File operations are only permitted from mount points".This could stop data curruption or loss in many case as in this case "files with same name".I am agree with the intention not to support this type of operation,but a fix like above is what i am looking for.
Comment 4 Amar Tumballi 2012-08-23 02:44:51 EDT
This bug is not seen in current master branch (which will get branched as RHS 2.1.0 soon). To consider it for fixing, want to make sure this bug still exists in RHS servers. If not reproduced, would like to close this.
Comment 5 Amar Tumballi 2012-08-23 06:05:05 EDT
Need clear documentation about not touching anything directly in backend

Note You need to log in before you can comment on or make changes to this bug.