Bug 822987 - Booting Virtual Machines from custom initrd/kernel images.
Booting Virtual Machines from custom initrd/kernel images.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cheryn Tan
ecs-bugs
: Documentation
: 856734 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 13:28 EDT by Stephen Gordon
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 12:22:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 6 Cheryn Tan 2012-09-25 02:19:51 EDT
Changed table entry to read:

Linux Boot Options

The following options boot a Linux kernel directly instead of through the BIOS bootloader.

  *  kernel path - A fully-qualified path to a kernel image to boot the virtual machine. The kernel image must be stored on either the ISO domain (path name in the format of iso://path-to-image) or on the host's local storage domain (path name in the format of /data/images).

  *  initrd path - A fully-qualified path to a ramdisk image to be used with the previously specified kernel. The ramdisk image must be stored on the ISO domain (path name in the format of iso://path-to-image) or on the host's local storage domain (path name in the format of /data/images).

  *  kernel params - Kernel command line parameter strings to be used with the defined kernel on boot. 

In both Table 8.8. Virtual Machine: Boot Options Settings and Table 8.10. Virtual Machine: Run Once Settings

Does this fulfill the bug requirement? Does it need any more information?
Comment 7 Cheryn Tan 2012-09-25 02:20:25 EDT
*** Bug 856734 has been marked as a duplicate of this bug. ***
Comment 8 Stephen Gordon 2012-09-25 09:10:15 EDT
I think that looks much better, thanks!

Note You need to log in before you can comment on or make changes to this bug.