Bug 823091 - lxpanel freezes, a few other problems with LXDE
lxpanel freezes, a few other problems with LXDE
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lxpanel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-18 22:12 EDT by Andrew Lei
Modified: 2013-05-18 15:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-18 15:52:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Lei 2012-05-18 22:12:56 EDT
Description of problem:
1. Occasionally, lxpanel will freeze. It stops responding to any clicks or keyboard shortcuts, closed processes will still appear, and new processes will fail to appear. This happens once every one or two weeks. This occurred in Fedora 16 as well, but I had thought it might be due to a configuration problem or something in installing LXDE since my system originally ran GNOME

2. I don't know what component to put this under, but LXDE has frozen on me entirely about two or three times since the launch day of Fedora 17. I haven't tested it with other DEs, and it might not be a DE issue, since CTRL+ALT+BACKSPACE fails, as do attempts to switch to a virtual terminal.

Version-Release number of selected component (if applicable):
Fedora 17 for both
Fedora 16 for the first one

How reproducible:
Occurs fairly infrequently with continuous uptime. I use a laptop, and the first one occurs sometimes after coming out of sleep mode. Lxpanel either fails to work or I just notice it when I close a window.

The second issue occurs much less frequently.
Comment 1 Christoph Wickert 2012-06-10 14:58:26 EDT
I am pretty sure that the problems listed under 2. have nothing to do with lxpanel. It seems your whole machine or at least the Xserver crashes. Can you ping it over the network when it is frozen?

As for the freezing panel, please try the update from https://admin.fedoraproject.org/updates/lxpanel-0.5.9-1.fc16 or
https://admin.fedoraproject.org/updates/lxpanel-0.5.9-1.fc17 if you are already using Fedora 17.
Comment 2 Christoph Wickert 2013-05-18 13:24:47 EDT
Andrew, can you please get back to me and tell us if you still have this problem?

There have been various updates in the meantime. The latest one is 
https://admin.fedoraproject.org/updates/FEDORA-2013-8069/lxpanel-0.5.12-2.fc17

Please give it a try.
Comment 3 Andrew Lei 2013-05-18 15:00:20 EDT
Cristoph:

No, I have not had this issue for a while. I have had an issue with lxpanel crashing when I close pidgin, though, but it's fairly manageable and not much of a problem as it immediately comes back up again. But I have not had any issues with freezing for a while.
Comment 4 Christoph Wickert 2013-05-18 15:52:04 EDT
(In reply to comment #3)
> I have had an issue with lxpanel
> crashing when I close pidgin, though, but it's fairly manageable and not
> much of a problem as it immediately comes back up again.

This is probably bug 587430, which should finally be fixes with the latest update.

> But I have not had any issues with freezing for a while.

Thanks for the feedback, I'll close this but then.

Note You need to log in before you can comment on or make changes to this bug.