This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 823221 - ruby package should not depend on rubygems
ruby package should not depend on rubygems
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 21:20 EDT by Tim Cuthbertson
Modified: 2012-05-21 07:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 03:24:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Cuthbertson 2012-05-19 21:20:21 EDT
Description of problem:

Apologies if I'm missing something, I tried to find a rationale for this on the package page or sources, but couldn't. It seems wrong that ruby (the interpreter) depends on rubygems (a package manager).

Some relevant examples for other languages:

 - python does not depend on python-setuptools
 - ghc does not depend on cabal-install
 - perl does not depend on perl-CPAN

I care because I want to write & test zeroinstall feeds for ruby libraries, and having rubygems installed on the system makes this more complicated (plus I simply don't want it).
Comment 1 Vít Ondruch 2012-05-21 03:24:50 EDT
Hi Tim,

I understand your sentiment. However, this was upstream decision to make RubyGems hard dependency. There is possible to build Ruby with disabled RubyGems, but it make break expectation of others.

You may try to submit patch upstream, which would use RubyGems in case they are available and works also fine when they are not present on the system (e.g. change gem_prelude.rb file to contains something like:

if defined?(Gem)
  begin
    require 'rubygems.rb'
  rescue
  end
end

), but I doubt it would be accepted since there are talks about gemyfying stdlib, etc.
Comment 2 Tim Cuthbertson 2012-05-21 07:25:40 EDT
Thanks for the explanation, Vit. I am used to debian which ships ruby on its own, but I also know that people moan about debian breaking rubygems ;). I might see what they do, and possibly roll my own ruby install if it's not too hairy.

Note You need to log in before you can comment on or make changes to this bug.