Bug 823301 - Mock fails to create Fedora's chroot environments
Mock fails to create Fedora's chroot environments
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: mock (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 13:45 EDT by Andrea Veri
Modified: 2012-06-08 03:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 03:59:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Veri 2012-05-20 13:45:24 EDT
Description of problem: Trying to create a Fedora's chroot on RHEL 6.2 fails with the following output:

DEBUG util.py:257:  RPM needs to be updated
DEBUG util.py:257:  ERROR You need to update rpm to handle:
DEBUG util.py:257:  rpmlib(X-CheckUnifiedSystemdir) necessario a filesystem-3-2.fc17.i686
DEBUG util.py:257:  rpmlib(X-CheckUnifiedSystemdir) necessario a setup-2.8.48-1.fc17.noarch
DEBUG util.py:257:   You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component:

1. mock: mock-1.1.21-1.el6.noarch
2. rpm: rpm-4.8.0-19.el6_2.1.x86_64

Steps to Reproduce:
Grab an SRPM and setup a new chroot with:

'mock -r fedora-17-i386 --init'

The command fails with the output outlined above.
Comment 1 LightDot 2012-05-31 20:15:35 EDT
Just got hit by this, same error. I'm unable to build Fedora 17 packages on my EPEL/SL 6.2 build system.

Are there any clean workarounds?
Comment 2 Andrea Veri 2012-06-01 05:36:36 EDT
Not that I know of at this moment of time, I am raising bug's severity since it makes mock being unusable when building packages for f17 and I guess f18 too.
Comment 3 Marko Myllynen 2012-06-08 03:59:16 EDT
As the error message says, this is an issue with RPM, not with Mock.

I can confirm that Mock on RHEL 6.3 Snapshot 4 already can build F17 RPMs.

Note You need to log in before you can comment on or make changes to this bug.