Bug 823305 - SELinux is preventing wicd from 'open' accesses on the file /var/log/wicd.log.
SELinux is preventing wicd from 'open' accesses on the file /var/log/wicd.log.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f1d9bcbfb8817bd2d44bd8e70c3...
:
: 914824 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 15:05 EDT by kunw
Modified: 2013-02-25 07:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-22 05:12:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kunw 2012-05-20 15:05:48 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.5-2.fc16.x86_64
reason:         SELinux is preventing wicd from 'open' accesses on the file /var/log/wicd.log.
time:           Sun 20 May 2012 11:37:48 AM PDT

description:
:SELinux is preventing wicd from 'open' accesses on the file /var/log/wicd.log.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that wicd should be allowed open access on the wicd.log file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep wicd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:NetworkManager_t:s0
:Target Context                unconfined_u:object_r:var_log_t:s0
:Target Objects                /var/log/wicd.log [ file ]
:Source                        wicd
:Source Path                   wicd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-1.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-84.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.5-2.fc16.x86_64 #1 SMP Tue May 8
:                              11:24:50 UTC 2012 x86_64 x86_64
:Alert Count                   12
:First Seen                    Sat 19 May 2012 03:48:47 PM PDT
:Last Seen                     Sun 20 May 2012 11:37:01 AM PDT
:Local ID                      69ab5066-43e6-430a-8fdb-373e0a98e6cb
:
:Raw Audit Messages
:type=AVC msg=audit(1337539021.564:65): avc:  denied  { open } for  pid=2170 comm="wicd" name="wicd.log" dev="dm-1" ino=1840 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=unconfined_u:object_r:var_log_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1337539021.564:65): arch=x86_64 syscall=open success=no exit=EACCES a0=1a943a0 a1=441 a2=1b6 a3=238 items=0 ppid=1 pid=2170 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=wicd exe=/usr/bin/python2.7 subj=system_u:system_r:NetworkManager_t:s0 key=(null)
:
:Hash: wicd,NetworkManager_t,var_log_t,file,open
:
:audit2allow
:
:#============= NetworkManager_t ==============
:allow NetworkManager_t var_log_t:file open;
:
:audit2allow -R
:
:#============= NetworkManager_t ==============
:allow NetworkManager_t var_log_t:file open;
:
Comment 1 Miroslav Grepl 2012-05-22 05:12:12 EDT
Please, execute

# restorecon -R -v /var/log/wicd.log

will fix.
Comment 2 Miroslav Grepl 2013-02-25 07:11:49 EST
*** Bug 914824 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.