Bug 823329 - queued_recipes routine in beakerd uses one-to-many joins
queued_recipes routine in beakerd uses one-to-many joins
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.8
Unspecified Unspecified
unspecified Severity high (vote)
: 0.9.0
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 19:26 EDT by Dan Callaghan
Modified: 2012-06-26 02:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 02:40:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-05-20 19:26:27 EDT
In beakerd:

    def queued_recipes(*args):
        recipes = Recipe.query\
                        .join(Recipe.recipeset, RecipeSet.job)\
                        .join(Recipe.systems)\
                        ...

This is a problem because it will cause many duplicate rows to be returned, so beakerd will process the same recipe over and over.

I'm not sure, but I suspect this is causing long delays with beakerd running at 100% CPU.
Comment 1 Dan Callaghan 2012-06-06 00:04:35 EDT
On Gerrit: http://gerrit.beaker-project.org/1119
Comment 3 Dan Callaghan 2012-06-26 02:40:44 EDT
Beaker 0.9.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.