Bug 823459 - Task view throws exception on the first run
Task view throws exception on the first run
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse-mylyn (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 06:16 EDT by Hedayat Vatankhah
Modified: 2014-01-12 19:27 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-22 08:42:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Eclipse log for the first run (mylyn exception) (353.86 KB, text/x-log)
2012-05-22 06:38 EDT, Hedayat Vatankhah
no flags Details
Reconciliation log (702.54 KB, text/x-log)
2012-05-22 08:11 EDT, Krzysztof Daniel
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 297769 None None None Never

  None (edit)
Description Hedayat Vatankhah 2012-05-21 06:16:29 EDT
Description of problem:
when I run Eclipse in a fresh installation of Fedora 17 (RC2 and also TC5), Mylyn's task view shows an exception. If I close Eclipse and run it again, task view works fine.

Version-Release number of selected component (if applicable):
eclipse-mylyn-3.7.0-5.fc17.noarch
eclipse-platform-4.2.0-0.20.I201205031800.fc17.x86_64
(Installed from installation DVD)


How reproducible:
100%
Comment 1 Krzysztof Daniel 2012-05-22 06:02:23 EDT
It would be good if you could attach the stacktrace.
Comment 2 Hedayat Vatankhah 2012-05-22 06:38:04 EDT
Created attachment 585995 [details]
Eclipse log for the first run (mylyn exception)
Comment 3 Krzysztof Daniel 2012-05-22 08:11:13 EDT
Created attachment 586017 [details]
Reconciliation log

Thanks for the log!

I have reproduced the issue. I'm working on it.
Comment 4 Krzysztof Daniel 2012-05-22 08:33:07 EDT
This is the source of all evilness - almost all bundles are affected:

Caused by: java.lang.LinkageError: loader constraint violation in interface itable initialization: when resolving method "org.eclipse.core.internal.plugins.PluginDescriptor.getPlugin()Lorg/eclipse/core/runtime/Plugin;" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, org/eclipse/core/internal/plugins/PluginDescriptor, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for interface org/eclipse/core/runtime/IPluginDescriptor have different Class objects for the type or.getPlugin()Lorg/eclipse/core/runtime/Plugin; used in the signature
	at org.eclipse.core.internal.plugins.PluginRegistry.getPluginDescriptor(PluginRegistry.java:117)
	at org.eclipse.core.internal.plugins.PluginRegistry.getPluginDescriptor(PluginRegistry.java:104)
	at org.eclipse.core.runtime.Platform.getPlugin(Platform.java:744)
	at org.eclipse.core.internal.preferences.legacy.InitLegacyPreferences.init(InitLegacyPreferences.java:43)
	at org.eclipse.core.internal.preferences.PreferenceServiceRegistryHelper.applyRuntimeDefaults(PreferenceServiceRegistryHelper.java:147)
	at org.eclipse.core.internal.preferences.PreferencesService.applyRuntimeDefaults(PreferencesService.java:368)
	at org.eclipse.core.internal.preferences.DefaultPreferences.applyRuntimeDefaults(DefaultPreferences.java:166)
	at org.eclipse.core.internal.preferences.DefaultPreferences.load(DefaultPreferences.java:237)
	at org.eclipse.core.internal.preferences.EclipsePreferences.create(EclipsePreferences.java:410)
	at org.eclipse.core.internal.preferences.EclipsePreferences.internalNode(EclipsePreferences.java:663)
	at org.eclipse.core.internal.preferences.EclipsePreferences.node(EclipsePreferences.java:805)
	at org.eclipse.core.internal.preferences.AbstractScope.getNode(AbstractScope.java:38)
	at org.eclipse.core.runtime.preferences.DefaultScope.getNode(DefaultScope.java:76)
	at org.eclipse.ui.preferences.ScopedPreferenceStore.getDefaultPreferences(ScopedPreferenceStore.java:250)
	at org.eclipse.ui.preferences.ScopedPreferenceStore.setDefault(ScopedPreferenceStore.java:618)
	at org.eclipse.mylyn.internal.monitor.ui.MonitorUiPlugin.start(MonitorUiPlugin.java:137)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
	... 50 more
Comment 5 Krzysztof Daniel 2012-05-22 08:42:49 EDT
Mystery solved.

Thank you, Hedayat, for your bug report. This is a problem of Mylyn, which they have known for a long time. I'll inform them that it affects all Fedora users.
Comment 6 Hedayat Vatankhah 2012-05-22 14:07:21 EDT
Thanks a lot for following this bug :)

Note You need to log in before you can comment on or make changes to this bug.