Bug 823465 - Add comment text field location moved
Add comment text field location moved
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 06:22 EDT by Daniel Berrange
Modified: 2014-10-12 18:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 08:17:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
when I place "new comment" after other (185.62 KB, image/jpeg)
2012-05-22 02:23 EDT, xiali
no flags Details

  None (edit)
Description Daniel Berrange 2012-05-21 06:22:09 EDT
Description of problem:
The "Add comment" text field location has moved from the bottom of the page, to the top of the page. Since the comments are still sorted "Oldest to newest" it means you have to now scroll to the bottom of the page to read the latest info, and then scroll back to the top of the page to reply to it. Double the amount of scrolling which is very tedious for long bugs.

Either the "Add comment" text field needs to be back at the bottom of the page, or the comment order needs to be reversed to "Newest to oldest". Either way would avoid so much scrolling of the page.

Version-Release number of selected component (if applicable):
4.2

How reproducible:
Always

Steps to Reproduce:
1. View a bug
2.
3.
  
Actual results:
Add comment form is next to the oldest comment

Expected results:
Add comment form is next to the newest comment.

Additional info:
Comment 1 Simon Green 2012-05-21 08:17:04 EDT
(In reply to comment #0)
> Description of problem:
> The "Add comment" text field location has moved from the bottom of the page,
> to the top of the page. Since the comments are still sorted "Oldest to
> newest" it means you have to now scroll to the bottom of the page to read
> the latest info, and then scroll back to the top of the page to reply to it.
> Double the amount of scrolling which is very tedious for long bugs.
> 
> Either the "Add comment" text field needs to be back at the bottom of the
> page, or the comment order needs to be reversed to "Newest to oldest".
> Either way would avoid so much scrolling of the page.

I'm going to stick with the Bugzilla defaults (add comments above comments, and sort oldest to newest). This will make it easier for people using other Bugzilla 4.0+ installations.

Personally, I have set add comments at the bottom of the page. It's a setting in the Preferences page for a reason.

  -- simon
Comment 2 xiali 2012-05-22 02:14:39 EDT
Maybe "This will make it easier for people using other Bugzilla 4.0+ installations."

But it makes harder for people using bugzilla.redhat.com, most user will not like this.

Please consider about moving it back.
Comment 3 xiali 2012-05-22 02:23:22 EDT
Created attachment 585930 [details]
when I place "new comment" after other

And when I place "new comment" after other, user interface screwed.

Note You need to log in before you can comment on or make changes to this bug.