Bug 823475 - Cannot hear sound in guest through remote-viewer.
Cannot hear sound in guest through remote-viewer.
Status: CLOSED DUPLICATE of bug 949241
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 06:56 EDT by Geyang Kong
Modified: 2013-08-04 23:43 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 11:39:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geyang Kong 2012-05-21 06:56:21 EDT
Description of problem:
  Cannot hear sound in guest through remote-viewer.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-8.el6.x86_64
libvirt-0.9.10-20.el6.x86_64
virt-viewer-0.5.2-8.el6.x86_64
qemu-kvm-0.12.1.2-2.294.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Make sure there is a running spice guest with audio device.
2. Make sure spice device listen to 0.0.0.0
3. Run #remote-viewer spice://iport --debug
4. Run #remote-viewer spice://127.0.0.1:port --debug
5. Run #virt-viewer $guestname
6. Run #virt-viewer --direct --connect=qemu+ssh://ip $guestname
7. Run #spicec -h ip -p port

Actual results:
1. After step 3. Nothing can be heard.
2. After step 4,5,6,7. Sounds from guest can be heard.

Expected results:
1. Sounds from guest can always be heard.

Additional info:
-------------Following is the debug information---------------------------------
[root@KP-T2 images]# remote-viewer spice://10.66.5.65:5900 --debug
** (remote-viewer:10537): DEBUG: Insert window 0 0x1c7d860
** (remote-viewer:10537): DEBUG: fullscreen display 0: 0
** (remote-viewer:10537): DEBUG: fullscreen display 0: 0
** (remote-viewer:10537): DEBUG: Opening display to spice://10.66.5.65:5900
** (remote-viewer:10537): DEBUG: Guest spice://10.66.5.65:5900 has a spice display

** (remote-viewer:10537): DEBUG: After open connection callback fd=-1
** (remote-viewer:10537): DEBUG: Opening connection to display at spice://10.66.5.65:5900

** (remote-viewer:10537): DEBUG: New spice channel 0x1cdf060 SpiceMainChannel 0
** (remote-viewer:10537): DEBUG: Checking full screen auto-conf
** (remote-viewer:10537): DEBUG: notebook show status 0x1c7e070
** (remote-viewer:10537): DEBUG: main channel: opened
** (remote-viewer:10537): DEBUG: New spice channel 0x1d71c00 SpiceCursorChannel 0
** (remote-viewer:10537): DEBUG: New spice channel 0x1d66000 SpiceDisplayChannel 0
** (remote-viewer:10537): DEBUG: notebook show status 0x1c7e070
** (remote-viewer:10537): DEBUG: new display channel (#0)
** (remote-viewer:10537): DEBUG: notebook show status 0x1c7e070
** (remote-viewer:10537): DEBUG: New spice channel 0x1de0800 SpiceInputsChannel 0
** (remote-viewer:10537): DEBUG: new inputs channel
** (remote-viewer:10537): DEBUG: Display size request 100x100 (desktop 100x100)
** (remote-viewer:10537): DEBUG: Allocated 400x375
** (remote-viewer:10537): DEBUG: Child allocate 375x375
** (remote-viewer:10537): DEBUG: Display size request 50x50 (desktop 100x100)
** (remote-viewer:10537): DEBUG: Allocated 400x375
** (remote-viewer:10537): DEBUG: Child allocate 375x375
** (remote-viewer:10537): DEBUG: spice desktop resize 640x480
** (remote-viewer:10537): DEBUG: Preparing main window resize
** (remote-viewer:10537): DEBUG: Decided todo 640x480 (desktop is 640x480, fullscreen is 1680x1050
** (remote-viewer:10537): DEBUG: Display size request 640x480 (desktop 640x480)
** (remote-viewer:10537): DEBUG: Allocated 640x480
** (remote-viewer:10537): DEBUG: Child allocate 640x480
** (remote-viewer:10537): DEBUG: Display size request 50x50 (desktop 640x480)
** (remote-viewer:10537): DEBUG: Allocated 640x480
** (remote-viewer:10537): DEBUG: Child allocate 640x480
** (remote-viewer:10537): DEBUG: Toggle monitor visibility 0x1d66000 1
** (remote-viewer:10537): DEBUG: notebook show display 0x1c7e070
** (remote-viewer:10537): DEBUG: spice desktop resize 720x400
** (remote-viewer:10537): DEBUG: Preparing main window resize
** (remote-viewer:10537): DEBUG: Decided todo 720x400 (desktop is 720x400, fullscreen is 1680x1050
** (remote-viewer:10537): DEBUG: Display size request 720x400 (desktop 720x400)
** (remote-viewer:10537): DEBUG: Toggle monitor visibility 0x1d66000 1
** (remote-viewer:10537): DEBUG: Allocated 720x400
** (remote-viewer:10537): DEBUG: Child allocate 720x400
** (remote-viewer:10537): DEBUG: Display size request 50x50 (desktop 720x400)
** (remote-viewer:10537): DEBUG: Allocated 720x400
** (remote-viewer:10537): DEBUG: Child allocate 720x400
** (remote-viewer:10537): DEBUG: spice desktop resize 640x400
** (remote-viewer:10537): DEBUG: Preparing main window resize
** (remote-viewer:10537): DEBUG: Decided todo 640x400 (desktop is 640x400, fullscreen is 1680x1050
** (remote-viewer:10537): DEBUG: Display size request 640x400 (desktop 640x400)
** (remote-viewer:10537): DEBUG: Toggle monitor visibility 0x1d66000 1
** (remote-viewer:10537): DEBUG: Allocated 640x400
** (remote-viewer:10537): DEBUG: Child allocate 640x400
** (remote-viewer:10537): DEBUG: Display size request 50x50 (desktop 640x400)
** (remote-viewer:10537): DEBUG: Allocated 640x400
** (remote-viewer:10537): DEBUG: Child allocate 640x400
** (remote-viewer:10537): DEBUG: spice desktop resize 720x400
** (remote-viewer:10537): DEBUG: Preparing main window resize
** (remote-viewer:10537): DEBUG: Decided todo 720x400 (desktop is 720x400, fullscreen is 1680x1050
** (remote-viewer:10537): DEBUG: Display size request 720x400 (desktop 720x400)
** (remote-viewer:10537): DEBUG: Toggle monitor visibility 0x1d66000 1
** (remote-viewer:10537): DEBUG: Allocated 720x400
** (remote-viewer:10537): DEBUG: Child allocate 720x400
** (remote-viewer:10537): DEBUG: Display size request 50x50 (desktop 720x400)
** (remote-viewer:10537): DEBUG: Allocated 720x400
** (remote-viewer:10537): DEBUG: Child allocate 720x400
** (remote-viewer:10537): DEBUG: spice desktop resize 640x400
** (remote-viewer:10537): DEBUG: Preparing main window resize
** (remote-viewer:10537): DEBUG: Decided todo 640x400 (desktop is 640x400, fullscreen is 1680x1050
** (remote-viewer:10537): DEBUG: Display size request 640x400 (desktop 640x400)
** (remote-viewer:10537): DEBUG: Toggle monitor visibility 0x1d66000 1
** (remote-viewer:10537): DEBUG: Allocated 640x400
** (remote-viewer:10537): DEBUG: Child allocate 640x400
** (remote-viewer:10537): DEBUG: Display size request 50x50 (desktop 640x400)
** (remote-viewer:10537): DEBUG: Allocated 640x400
** (remote-viewer:10537): DEBUG: Child allocate 640x400
** (remote-viewer:10537): DEBUG: spice desktop resize 720x400
** (remote-viewer:10537): DEBUG: Preparing main window resize
** (remote-viewer:10537): DEBUG: Decided todo 720x400 (desktop is 720x400, fullscreen is 1680x1050
** (remote-viewer:10537): DEBUG: Display size request 720x400 (desktop 720x400)
** (remote-viewer:10537): DEBUG: Toggle monitor visibility 0x1d66000 1
** (remote-viewer:10537): DEBUG: Allocated 720x400
** (remote-viewer:10537): DEBUG: Child allocate 720x400
** (remote-viewer:10537): DEBUG: Display size request 50x50 (desktop 720x400)
** (remote-viewer:10537): DEBUG: Allocated 720x400
** (remote-viewer:10537): DEBUG: Child allocate 720x400
** (remote-viewer:10537): DEBUG: spice desktop resize 720x400
** (remote-viewer:10537): DEBUG: Toggle monitor visibility 0x1d66000 1
** (remote-viewer:10537): DEBUG: spice desktop resize 720x400
** (remote-viewer:10537): DEBUG: Toggle monitor visibility 0x1d66000 1
** (remote-viewer:10537): DEBUG: spice desktop resize 1024x768
** (remote-viewer:10537): DEBUG: Preparing main window resize
** (remote-viewer:10537): DEBUG: Decided todo 1024x768 (desktop is 1024x768, fullscreen is 1680x1050
** (remote-viewer:10537): DEBUG: Display size request 1024x768 (desktop 1024x768)
** (remote-viewer:10537): DEBUG: Toggle monitor visibility 0x1d66000 1
** (remote-viewer:10537): DEBUG: Allocated 1024x768
** (remote-viewer:10537): DEBUG: Child allocate 1024x768
** (remote-viewer:10537): DEBUG: Display size request 50x50 (desktop 1024x768)
** (remote-viewer:10537): DEBUG: Allocated 1024x768
** (remote-viewer:10537): DEBUG: Child allocate 1024x768
--------------------------------------------------------------------------------
Comment 2 Geyang Kong 2012-05-31 01:08:41 EDT
This bug can only be reproduced by es1370 audio device, others will be OK.
Comment 4 RHEL Product and Program Management 2012-07-10 02:58:34 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 22:01:44 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Daniel Berrange 2012-07-26 13:41:58 EDT
Given comment #2, this could well be a bug in the QEMU hardware emulation for that device type.
Comment 9 Marc-Andre Lureau 2013-05-08 11:39:13 EDT
Since it's only with es1370 audio device, and this is spice related it can't be filed under virt-viewer. There is a qemu bug 949241 for it already, closing as dup

*** This bug has been marked as a duplicate of bug 949241 ***

Note You need to log in before you can comment on or make changes to this bug.