Bug 823487 - glibc i386 can't be rebuild in mock
glibc i386 can't be rebuild in mock
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: glibc (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jeff Law
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 07:30 EDT by Levente Farkas
Modified: 2016-11-24 10:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 23:31:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2012-05-21 07:30:10 EDT
there are two problem when building glibc-2.5-81 on rhel-5.8 in mock since there are two bad dir
- /usr/share/info/dir
 is owned by info package and shouldn't have to be created by glibc

/var/tmp/glibc-2.5-root/usr/src/debug/glibc-2.5-20061008T1257/inet/<built-in>
is created by accident.


here is the relevant build.log section:
-------------------------------------
Requires: glibc-debuginfo-common = 2.5-81
Processing files: glibc-debuginfo-common-2.5-81
error: File not found: /var/tmp/glibc-2.5-root/usr/src/debug/glibc-2.5-20061008T1257/inet/<built-in>
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/glibc-2.5-root
warning: Installed (but unpackaged) file(s) found:
   /usr/share/info/dir
-------------------------------------
Comment 1 Jeff Law 2012-05-21 16:41:51 EDT
The debug problem with <built-in> has already been fixed and the fix will be included in RHEL 5.9.  I'll have to look at the /usr/share/info/dir problem.
Comment 2 Levente Farkas 2012-05-21 16:44:56 EDT
sorry it seems to be fixed in 5.8 updates. it was just a bug in original 5.8.
can be closed.
Comment 3 Jeff Law 2012-05-21 23:31:50 EDT
Per c#2.

Note You need to log in before you can comment on or make changes to this bug.