Bug 823514 - Gluster - Backend: Wrong error on failed rebalance
Gluster - Backend: Wrong error on failed rebalance
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Selvasundaram
Haim
gluster
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 08:47 EDT by Daniel Paikov
Modified: 2014-12-29 12:30 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-17 02:49:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Paikov 2012-05-21 08:47:45 EDT
When trying to rebalance a domain that is created from 1 brick, the error is "Error: Cannot start Gluster Volume. Gluster Volume is not distributed." The volume IS distributed, the problem is that it is created from 1 brick.

2012-05-21 15:40:13,010 WARN  [org.ovirt.engine.core.bll.gluster.StartRebalanceGlusterVolumeCommand] (ajp--0.0.0.0-8009-1) CanDoAction of action StartRebalanceGlusterVolume failed. Reasons:VAR__ACTION__START,VAR__TYPE__GLUSTER_VOLUME,ACTION_TYPE_FAILED_GLUSTER_VOLUME_IS_NOT_DISTRIBUTED
Comment 1 Selvasundaram 2012-05-24 07:42:41 EDT
fix submitted on http://gerrit.ovirt.org/#change,4752.
Comment 2 Selvasundaram 2012-05-24 09:36:57 EDT
Patch Id marked above is wrong. 
Fix submitted in the patch:  http://gerrit.ovirt.org/4774
Comment 3 Gilad Chaplik 2012-05-24 12:47:58 EDT
merged upstream (09823fd2170007fa9933ea1efaf7608b324c811f)
Comment 4 Daniel Paikov 2012-06-10 09:24:30 EDT
Rebalance button no longer exists, as of 9xJun.

Note You need to log in before you can comment on or make changes to this bug.