Bug 823521 - can't build tests rpm
can't build tests rpm
Status: CLOSED DUPLICATE of bug 600308
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
6.2
Unspecified Unspecified
high Severity low
: rc
: ---
Assigned To: Vitezslav Crhonek
qe-baseos-daemons
:
Depends On: 773604
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 09:02 EDT by Petr Sklenar
Modified: 2012-05-21 09:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 773604
Environment:
Last Closed: 2012-05-21 09:17:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2012-05-21 09:02:53 EDT
I can see the same on rhel63:

make[2]: Entering directory `/root/rpmbuild/BUILD/pegasus'
make[2]: Leaving directory `/root/rpmbuild/BUILD/pegasus'
make[2]: Entering directory `/root/rpmbuild/BUILD/pegasus'
cp: cannot stat `/root/rpmbuild/BUILD/pegasus/build/lib/libSampleInstanceProvider.so.1': No such file or directory
cp: cannot stat `/root/rpmbuild/BUILD/pegasus/build/lib/libSampleMethodProvider.so.1': No such file or directory
cp: cannot stat `/root/rpmbuild/BUILD/pegasus/build/lib/libFamilyProvider.so.1': No such file or directory
cp: cannot stat `/root/rpmbuild/BUILD/pegasus/build/lib/libIndicationStressTestConsumer.so.1': No such file or directory
cp: cannot stat `/root/rpmbuild/BUILD/pegasus/build/lib/libIndicationStressTestProvider.so.1': No such file or directory
cp: cannot stat `/root/rpmbuild/BUILD/pegasus/build/lib/libIndicationTestProvider.so.1': No such file or directory
make[2]: *** [stage_testproviderfiles] Error 1
make[2]: Leaving directory `/root/rpmbuild/BUILD/pegasus'
make[1]: *** [stageTEST] Error 2
make[1]: Leaving directory `/root/rpmbuild/BUILD/pegasus'
make: *** [stage] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.sB87bQ (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.sB87bQ (%install)


+++ This bug was initially created as a clone of Bug #773604 +++

Description of problem:
There's a possibility to build a subpackage with tog-pegasus tests.
From spec:

%{?!PEGASUS_BUILD_TEST_RPM:     %define PEGASUS_BUILD_TEST_RPM        0}
# do "rpmbuild --define 'PEGASUS_BUILD_TEST_RPM 1'" to build test RPM.

However, this doesn't work - rpmbuild fails while trying to copy some files, see below.


Version-Release number of selected component (if applicable):
tog-pegasus-2.11.0-2.el5


How reproducible:
always


Steps to Reproduce:
1. rpmbuild --rebuild --define 'PEGASUS_BUILD_TEST_RPM 1' tog-pegasus-2.11.0-2.el5.src.rpm

  
Actual results:
...
make[2]: Entering directory `/usr/src/redhat/BUILD/pegasus'
cp: cannot stat `/usr/src/redhat/BUILD/pegasus/build/lib/libSampleInstanceProvider.so.1': No such file or directory
cp: cannot stat `/usr/src/redhat/BUILD/pegasus/build/lib/libSampleMethodProvider.so.1': No such file or directory
cp: cannot stat `/usr/src/redhat/BUILD/pegasus/build/lib/libFamilyProvider.so.1': No such file or directory
cp: cannot stat `/usr/src/redhat/BUILD/pegasus/build/lib/libIndicationStressTestConsumer.so.1': No such file or directory
cp: cannot stat `/usr/src/redhat/BUILD/pegasus/build/lib/libIndicationStressTestProvider.so.1': No such file or directory
cp: cannot stat `/usr/src/redhat/BUILD/pegasus/build/lib/libIndicationTestProvider.so.1': No such file or directory
make[2]: *** [stage_testproviderfiles] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/pegasus'
make[1]: *** [stageTEST] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/pegasus'
make: *** [stage] Error 2
error: Špatný návratový kód z /var/tmp/rpm-tmp.11216 (%install)


Expected results:
(no errors, packages built)


Additional info:
note that this hasn't worked in the previous version too but the error was different:

rpmbuild --rebuild --define 'PEGASUS_BUILD_TEST_RPM 1' tog-pegasus-2.9.1-2.el5_5.1.src.rpm
...
make[1]: Leaving directory `/usr/src/redhat/BUILD/pegasus/src/Providers/sample/MethodProvider'
make: *** No rule to make target `/usr/src/redhat/BUILD/pegasus/build/lib/libIndicationTestProvider.so.1', needed by `tests'.  Stop.
error: Špatný návratový kód z /var/tmp/rpm-tmp.66964 (%build)
Comment 2 Petr Sklenar 2012-05-21 09:17:46 EDT

*** This bug has been marked as a duplicate of bug 600308 ***

Note You need to log in before you can comment on or make changes to this bug.