Bug 82364 - X i815 fails in 16-bit color depth when switching VCs
X i815 fails in 16-bit color depth when switching VCs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-21 12:25 EST by Chris Ricker
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 15:30:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-01-21 12:25:16 EST
Fresh installs of RHL 8.0, fully updated

These machines (Gateway e-3400s) have i815 video chipsets. They fail ~50% of the
time when switching from a running 16-bit 1024x768 X session to a text VC; they
switch, but when you switch back to X, the X server has died

Switching to 24-bit 1024x768 seems to prevent this
Comment 1 Mike A. Harris 2003-01-24 09:14:45 EST
How about phoebe2?
Comment 2 Chris Ricker 2003-01-24 14:00:08 EST
phoebe 2 does seem to fix that

w/ both phoebe2 and 8, running multiple X servers is possible in 24-bit mode but
not in 16-bit mode (dies with agpgart errors when starting the second X). That's
probably a hardware / kernel issue, though, I would think?
Comment 3 Mike A. Harris 2003-01-24 15:30:44 EST
Running more than one X server simultaneously on a single video card
is not supported.  It works rather flawlessly with many combinations
of hardware, but not with others.  The failures tend to be video card
specific, or to be related to wether a given card is primary or
secondary (such as 3Dfx hardware), or it can be some other combination
of factors.

It is generally rather hardware specific.  Considering the number of
users who actually use multiple X servers simultaneously, compared
to the number of users who have reported inability to get just a single
head up and running and video working, bug troubleshooting/debugging
prioritizaiton must be assigned to getting hardware working for more
people who it does not, so special-case scenarios like multiple
X servers on one box, which are much rarer, take very low priority.
Rather than leave them sit at low priority, and most likely never get
any attention due to there always being higher priority bugs to fix,
my best recommendation would be to report issues like that directly
to xfree86@xfree86.org mailing list.

I'd rather be honest with you than leave such a bug open for 2 years and
not ever touch it simply due to prioritization.

Since you've indicated phoebe 2 resolves the originally reported issue,
closing RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.