Bug 823706 - Fedora 16 ABRT doesn't submit properly
Fedora 16 ABRT doesn't submit properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
: 823326 824206 825636 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 20:03 EDT by Fred Weigel
Modified: 2012-06-15 08:26 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 08:26:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred Weigel 2012-05-21 20:03:05 EDT
Description of problem: When using abrt in Fedora 16 to automatically report defects, an XML error is returned after checking for duplicates.


Version-Release number of selected component (if applicable):


How reproducible:

Every ABRT reported defect

Steps to Reproduce:
1. Choose an ABRT defect
2. Fill in report
3. Submit to Bugzilla
  
Actual results:

--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
Checking for duplicates
fatal: XML-RPC(0): (null)
(exited with 1)


Expected results:

Defect submitted, either duplicate report or new defect.

Additional info:

Started happening after Bugzilla upgrade. There was no update to ABRT. The Fedora 16 system is completely up to date wrt patches.
Comment 1 Fedora Update System 2012-05-22 03:15:55 EDT
libreport-2.0.10-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-8212/libreport-2.0.10-3.fc16
Comment 2 Jiri Moskovcak 2012-05-22 08:36:51 EDT
*** Bug 823375 has been marked as a duplicate of this bug. ***
Comment 3 Juhamatti Niemelä 2012-05-26 04:49:54 EDT
I had this same issue so I installed libreport-2.0.10-3.fc16 from updates-testing and tested it by reporting bug about simple-scan.

The bug[1] I was reporting was existing bug, so ABRT added my information as a comment like it should, but it didn't add me to that bug's cc list.

[1]: https://bugzilla.redhat.com/show_bug.cgi?id=771045
Comment 4 Tobias Mueller 2012-05-27 15:45:55 EDT
*** Bug 823326 has been marked as a duplicate of this bug. ***
Comment 5 Jiri Moskovcak 2012-05-28 08:58:41 EDT
*** Bug 825636 has been marked as a duplicate of this bug. ***
Comment 6 Jiri Moskovcak 2012-05-28 09:01:05 EDT
*** Bug 824206 has been marked as a duplicate of this bug. ***
Comment 7 Ian Laws 2012-06-04 02:06:45 EDT
Hi

I did the update to newest abrt (fc16) yesterday.
I tried to send a report that I still have.
Result:
fatal: XML-RPC(0): (null)
(exited with 1)


abrt-gui-2.0.7-3.fc16.x86_64
abrt-addon-python-2.0.7-3.fc16.x86_64
abrt-libs-2.0.7-3.fc16.x86_64
abrt-retrace-client-2.0.7-3.fc16.x86_64
abrt-addon-vmcore-2.0.7-3.fc16.x86_64
abrt-addon-kerneloops-2.0.7-3.fc16.x86_64
abrt-desktop-2.0.7-3.fc16.x86_64
abrt-addon-ccpp-2.0.7-3.fc16.x86_64
abrt-2.0.7-3.fc16.x86_64
Comment 8 Ian Laws 2012-06-09 13:06:52 EDT
Just installed libreport-2.0.8-4.fc16.x86_64 (as instructed in the bug 823375) from the repo updates and now reporting bugs works again.

Ian
Comment 9 Fedora Update System 2012-06-15 08:26:43 EDT
libreport-2.0.10-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.