Bug 823755 - shotwell-0.12.2-2.fc17 crash on first launch
shotwell-0.12.2-2.fc17 crash on first launch
Product: Fedora
Classification: Fedora
Component: shotwell (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-05-22 01:12 EDT by Charles R. Anderson
Modified: 2012-05-23 17:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-05-23 17:34:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
coredump (69.96 MB, application/octet-stream)
2012-05-22 01:12 EDT, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2012-05-22 01:12:14 EDT
Created attachment 585927 [details]

Description of problem:

Shotwell crashed with a signal 11 on the first launch.  Subsequent launches worked fine.

Process /usr/bin/shotwell was killed by signal 11 (SIGSEGV)

Version-Release number of selected component (if applicable):

How reproducible:
didn't try

Steps to Reproduce:
1. install F17 Final RC3 from DVD, using default package selections
2. launch Shotwell from Gnome Shell Overview Applications List

Actual results:

Expected results:
no crash

Additional info:
ABRT and gdb were both unable to generate a good backtrace, so I've attached the core file here.
Comment 1 Petr Schindler 2012-05-22 08:41:17 EDT
I'm unable to reproduce this bug. I installed system from RC3 live. Shotwell starts correctly, I haven't seen any isue.
Comment 2 Adam Williamson 2012-05-22 14:37:36 EDT
Also couldn't reproduce. Installed clean to a KVM VM from DVD, ran Shotwell from the Dash, it worked.

Did you have any kind of USB storage or a camera attached?
Comment 3 Charles R. Anderson 2012-05-22 15:01:05 EDT
The laptop does have a built-in camera that shows up as a USB device.
Comment 4 Thomas Moschny 2012-05-22 16:11:24 EDT
Does the problem persist with 0.12.3?

Comment 5 Charles R. Anderson 2012-05-22 23:34:26 EDT
I can't reproduce upon further tries with the original package.  I was performing Desktop tests when this happened, so perhaps the sequence of events leading up to this crash needs to be done in the same order.  Roughly speaking, I went through every icon in the overview applications list in order, and the crash happened when I got to shotwell.
Comment 6 Thomas Moschny 2012-05-23 17:34:49 EDT
So, closing for now. Feel free to reopen, if you see this problem again.

Note You need to log in before you can comment on or make changes to this bug.