Bug 823795 - systemd-logind first start fails which causes plasma-desktop to crash if logging immediately after system starts up
systemd-logind first start fails which causes plasma-desktop to crash if logg...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 03:36 EDT by Michal Piotrowski
Modified: 2012-06-11 08:33 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 08:33:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
plasma-desktop stack trace (10.51 KB, text/plain)
2012-05-22 03:36 EDT, Michal Piotrowski
no flags Details
NetworkManager crash info from /var/log/messages (25.71 KB, text/plain)
2012-05-22 04:02 EDT, Michal Piotrowski
no flags Details
A copy of /var/log/messages (91.33 KB, text/plain)
2012-05-25 02:28 EDT, Michal Piotrowski
no flags Details
dmesg with systemd debug logging (275.55 KB, text/plain)
2012-05-25 02:30 EDT, Michal Piotrowski
no flags Details
systemctl dump (465.41 KB, text/plain)
2012-05-25 02:31 EDT, Michal Piotrowski
no flags Details
output of /bin/systemd --test --system --log-level=debug (496.54 KB, text/plain)
2012-05-25 02:32 EDT, Michal Piotrowski
no flags Details

  None (edit)
Description Michal Piotrowski 2012-05-22 03:36:57 EDT
Created attachment 585948 [details]
plasma-desktop stack trace

Description of problem:
If I log in to KDE desktop immediately after system starts up, plasma-desktop crashes. Subsequent log ins don't cause the crash. Furthemore, if I wait some time after system start, then log to KDE desktop, the crash also does not occur.

Based on stack trace and /var/log/messages I suspect a problem with an interaction with NetworkManager. I am not sure which component is the cause of the crash: KDE or NetworkManager.

Version-Release number of selected component (if applicable):
kde-workspace-4.8.3-3.fc16.x86_64
NetworkManager-0.9.4-3.git20120403.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Log in to KDE desktop immediately after system starts up (the faster the better chance to reproduce the problem)
  
Actual results:
plasma-desktop crashes

Expected results:
plasma-desktop doesn't crash

Additional info:
I am attaching plasma-desktop stack-trace and relevant information from /var/log/messages
Comment 1 Michal Piotrowski 2012-05-22 04:02:40 EDT
Created attachment 585956 [details]
NetworkManager crash info from /var/log/messages

I attach relevant info from /var/log/messages about NetworkManager crash which occured at the same time as plasma-desktop crash.

I tried to install debug symbols for NetworkManager, but after that the crashes for NetworkManager weren't logged to /var/log/messages. plasma-desktop crashed as before, as explained in the report.
Comment 2 Kevin Kofler 2012-05-22 04:19:17 EDT
Both the crashes are inside D-Bus code, I wonder whether there's something wrong with D-Bus.
Comment 3 Michal Piotrowski 2012-05-22 04:38:32 EDT
Is it possible that systemd doesn't start D-Bus fast enough or that systemd doesn't wait for D-Bus to be fully started before displaying login screen?
Comment 4 Michal Piotrowski 2012-05-25 02:26:09 EDT
I have found out, that crash occurs when systemd-logind.service is in a failed state. The service always fails when it starts for the first time. Therefore I changed the description and component of the bug. I will attach systemd log files shortly.
Comment 5 Michal Piotrowski 2012-05-25 02:28:55 EDT
Created attachment 586776 [details]
A copy of /var/log/messages

A full copy of /var/log/message from one boot
Comment 6 Michal Piotrowski 2012-05-25 02:30:08 EDT
Created attachment 586777 [details]
dmesg with systemd debug logging
Comment 7 Michal Piotrowski 2012-05-25 02:31:21 EDT
Created attachment 586778 [details]
systemctl dump
Comment 8 Michal Piotrowski 2012-05-25 02:32:34 EDT
Created attachment 586779 [details]
output of /bin/systemd --test --system --log-level=debug
Comment 9 Michal Schmidt 2012-05-25 05:08:45 EDT
This is an unusual error:

[   22.913291] systemd[1]: RequestName() failed: Access denied

Do you have the pristine file /etc/dbus-1/system.d/org.freedesktop.systemd1.conf or are there any modifications or a possible corruption?
Comment 10 Michal Piotrowski 2012-05-26 01:53:23 EDT
I have the pristine file /etc/dbus-1/system.d/org.freedesktop.systemd1.conf. I have compared my file with the one from downloaded RPM package (systemd-37-19.fc16.x86_64.rpm) and the files are identical.
Comment 11 Lennart Poettering 2012-05-30 20:04:06 EDT
My guess is that some package installed a bogus D-Bus policy file which corrupts the whole boot.
Comment 12 Michal Schmidt 2012-06-07 03:36:26 EDT
Let's see what policy D-Bus files are there. Could you attach a tarball of everything in /etc/dbus-1/ ?
Comment 13 Michal Piotrowski 2012-06-11 08:33:06 EDT
I have upgraded my Fedora installation in the meantime and the problem doesn't appear in Fedora 17. Therefore I think I should close the bug and mark it as next release.

Note You need to log in before you can comment on or make changes to this bug.